Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 32-bit with Unity. My system configuration is:

  • CPU: Core 2 Quad Q6600 (2.4 GHz)
  • RAM: 8192 Mb DDR2 Kingston
  • Video: Palit GeForce GTX 260 216 SP, and my screen resolution is 1680x1050.

I also have Window 7 Ulitimate installed, and I can see the same files in Media Player Classic without any horizontal lines.

I've installed vdpau driver, NVIDIA drivers 304.51, and MPlayer 2 (within SMPlayer). I've disabled "Sync to VBlank" option in CCSM (because in other way, by default, MPlayer process use about 50-60 percents of my processor load), tried to swich between different deinterlace options in SMPlayer, used "-vc ffh264vdpau,ffmpeg12vdpau" (without quotes) parameters for MPlayer, switched to "Ubuntu 2D", but, finally, have no results.

Any suggestions? How must I to set up MPlayer?

I also attach screenshots of my SMPlayer's options:

enter image description here

Full size

share|improve this question

1 Answer 1

up vote 2 down vote accepted

One (drastic) change which can help is to disable Compositing completely via xorg.conf:

  1. Open the file /etc/X11/xorg.conf with an editor using sudo, for example by executing this command in a terminal: gksudo gedit /etc/X11/xorg.conf

    Note: If the file does not exist yet, you need to create it by following these instructions.

  2. Add these lines to the end of the file and save it:

    Section "Extensions"
        Option  "Composite" "Disable"
    EndSection
    
  3. Reboot (Alternative: Close all applications and force-restart the X Server itself by executing sudo service lightdm restart

Note that this procedure will make your desktop unable to display any kind of transparency or smooth desktop animations.

share|improve this answer
    
Thank you a lot. But I am sad this is the last chance to have nice HD playback is to haven't any effects on desktop. –  Guy Fawkes Oct 28 '12 at 9:57
    
Sorry to dig this 3 months old Q&A up. I'm not sure how this solves deinterlacing issues. It does seem to solve tearing (VSync) issues for users. @GuyFawkes: have you actually tried this solution? Perhaps you meant tearing instead of interlacing in your Q? –  gertvdijk Jan 5 '13 at 21:31
    
Yes, I actuall tried this solution. Tearing is like, as I know, "separated" screen, when one part is from "next" frame and another part is from some different frame. But in my case whole screen has some lags, and it can be changed by changing "deinterlace" options in video player settings. So I desire it's deinterlacing bug. –  Guy Fawkes Jan 6 '13 at 8:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.