Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For the last couple of days my wifi connection is extremely slow. I am pretty sure that it is caused by the driver. Can this be improved?

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"MyWiFi"  
      Mode:Managed  Frequency:2.437 GHz  Access Point: 00:18:63:FE:7A:C7   
      Bit Rate=58.5 Mb/s   Tx-Power=15 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=48/70  Signal level=-62 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:6960   Missed beacon:0

eth0      no wireless extensions.


sudo lshw -class network
*-network               
   description: Wireless interface
   product: AR9285 Wireless Network Adapter (PCI-Express)
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 01
   serial: 74:f0:6d:34:c2:4e
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.2.0-31-generic-pae firmware=N/A ip=192.168.1.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:17 memory:d7400000-d740ffff
*-network
   description: Ethernet interface
   product: AR8131 Gigabit Ethernet
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:06:00.0
   logical name: eth0
   version: c0
   serial: 48:9b:38:48:f3:ed
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI firmware=N/A latency=0 link=no multicast=yes port=twisted pair
   resources: irq:51 memory:d3800000-d383ffff ioport:8000(size=128)

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 04f2:b1bb Chicony Electronics Co., Ltd 
Bus 001 Device 004: ID 0b05:1788 ASUSTek Computer, Inc. 


lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 425M] (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 USB controller: Fresco Logic Device 1400 (rev 01)
06:00.0 Ethernet controller: Atheros Communications Inc. AR8131 Gigabit Ethernet (rev c0)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)


rfkill list all
0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
share|improve this question
add comment

3 Answers 3

Okay I have been having the same problem and I think I figured it out I think it is getting excessive power causing it to transmit more errors but I lowered my output using this command in terminal and I kid you not it runs better

sudo iwconfig wlan0 txpower 8B26
share|improve this answer
add comment

Previous answer I think you're on to something.

Context: I'm on Xubuntu 12.04 on the new acer aspire s7 ultrabook. My wireless was crazy unstable, disconnecting constantly and I had very unstable ping times to google.

First thing I did was install the driver from scratch from http://wireless.kernel.org/. And that didnt help.

Next I tried this: sudo iwconfig wlan0 txpower auto and all of a sudden I'm not disconnecting anymore and my pings to google are very solid, not varying much outside of 12ms consistently.

I just hope this setting persists a reboot.

share|improve this answer
    
Please, come back later and tell us if it works after a restart. Thanks! –  Lucio Mar 18 '13 at 22:56
    
This one worked for me... and held fast after a reboot. –  JoshP Dec 31 '13 at 4:36
add comment

I was having the same issues, but changing the tx power had no effect for me. I had to disable hw encryption. I did

sudo modprobe -r ath9k
sudo modprobe ath9k nohwencrypt=1

After reconnecting it worked great. To make the change permanent I did this

sudo -s
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

After a reboot I verified that wifi still worked well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.