Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried setting up a share on my Ubuntu 12.04 machine to my Win7 machine. I right clicked on a folder in Ubuntu and chose the Sharing options and gave it read and write permissions too. Now the problem is, I chose my Videos folder to be shared, but when I access it on my windows machine, I can see my whole system! To top it of, it has write permissions too. How do I revoke this and share only that one folder?

I deleted all the shares and tried smbclient -L localhost and I got

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.3]

Sharename       Type      Comment
---------       ----      -------
IPC$            IPC       IPC Service (xyz server (Samba, Ubuntu))
print$          Disk      Printer Drivers

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.3]

Server               Comment
---------            -------
XYZ                xyz server (Samba, Ubuntu)
ABPC            

Workgroup            Master
---------            -------
WORKGROUP            XYZ

which lists no shared folders, but I can still access them through my windows machine.

Other things I tried

net usershare list (lists nothing)

ls -l /var/lib/samba/usershares (returns total 0)


smbstatus --shares
Service      pid     machine       Connected at
-------------------------------------------------------
IPC$         8888   xyz         Wed Oct 10 21:56:22 2012
Videos       8625   abpc        Wed Oct 10 21:54:22 2012
IPC$         8767   xyz         Wed Oct 10 21:56:17 2012

I'm at my wits end. Someone please help me.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

It seems a reboot was required... facepalm

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.