Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did a fresh install of 12.04 by usb and it went fine, worked on it for several days, but one day the browser crashed and i reset the machine, after that I get this error when i boot;

error: no device connected
error: no device connected
error: no device connected
error: no device connected

This comes after the BIOS confirmation, and it stays for about 30 seconds, then the grub menu comes and when I selected the default the screen becomes purple and stays like that for a whole Minuit. I thought maybe that is because I have 500GB HDD so i ran the boot-repair, It did nothing at all. I'm sure I did the boot-repair thing right, sorry I forgot the paste URL. If i reinstalled will this error persist.

share|improve this question
How did you install Ubuntu: USB, CDrom...? – TardisGuy Oct 10 '12 at 16:10
after a usb install – Prabath Swarna Oct 11 '12 at 14:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.