Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've installed VSFTPD on my VPS running Ubuntu server 10.04. When connecting using FTP clients such as Filezilla it's working perfectly. However when I use my Drupal's native FTP client to update the modules and the core installation my "working" login credentials are not working.

So after searching the internet, there are some configurations that should be changed on "vsftpd.conf" which I followed and those instructions say that I should restart my VSFTPD.

So after trying these commands

sudo /etc/init.d/vsftpd restart
service vsftpd restart

Both results to *respectively

sudo: /etc/init.d/vsftpd: command not found
service vsftpd restart

Then there's another weird thing that went out when trying to find out the problem my self

When I type

ls -l /etc/init.d

It results to

lrwxrwxrwx 1 root root    21 Oct  2 06:29 vsftpd -> /lib/init/upstart-job

What could be wrong?

Any help would be GREATLY appreciated. Thanks in Advance!

share|improve this question
Did you find the solution to this issue?? I am facing the same problem. – naka Apr 28 '14 at 12:56
I have also got this error in my lubuntu. I had to try the following sudo restart vsftpd – Chandru May 31 '14 at 8:52
Use Command sudo service vsftpd restart – Lonston May 31 '14 at 10:09

1 Answer 1

up vote 3 down vote accepted

Use Command sudo service vsftpd restart

you can see below i have done

sysadmin@localhost:~$ sudo service vsftpd restart
vsftpd stop/waiting
vsftpd start/running, process 21140
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.