Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using awesome-wm on Kubuntu 10.10. I like some of the KDE tools... like choqok. Thing is, that within awesome wm it seems to be impossible to set a default browser, because KDE4 settings overwrite the generally desired settings:

To illustrate the problem:

% xdg-mime query default text/html  
chromium-browser.desktop

And from ~/.kde/share/config/kdeglobals

[General]
BrowserApplication=firefox.desktop

Which does in no way make sense to me. If I set Firefox as default xdg-mime should not have Chrome. In fact I want Firefox.

So how do I globally once and for all, across all frameworks, define Firefox as default?

Best, Marius

p.s.: I should probably mention, that clicking in Choqok starts Konqueror...

share|improve this question
    
Look for default apps in system settings? – karthick87 Jan 3 '11 at 17:22
    
aehm... did you read this question at all? – wishi Jan 3 '11 at 17:25
up vote 4 down vote accepted

I go to the start menu, then:

System Settings->Default Applications->Web Browser

and then I tell it to open http/https in:
google-chrome

Now links in choqok (or any other kde application) are opened in chrome, also, if I do alt+f2 and type "man:file" for instance, the man page opens in chrome.

I also modified the default email client so that emails are launched using gmail using the following command:

google-chrome "https://mail.google.com/mail/?view=cm&fs=1&tf=1&to="%t

share|improve this answer
    
Very handy! default browser worked like a charm. But that email line didn't work from gwenvew for sharing an image - the image itself wasn't loaded as an attachment. Can that be made to work as well? – nealmcb Nov 9 '15 at 19:57

I have here KDE 4.6 (Beta of course) but am sure this worked in 4.5.x because i was opening everything with Firefox.

Right click on a html file, choose properties and on the window that appears click on the small button next to the format of the file (html in this example). The button is small and to the right of the format. There you can choose which one will be the default one. The default one should be on top, the first one in the list will be the default for all html files.

I did this for avi, mpg, mp3, png, jpg, htm, php, js, css files.

share|improve this answer

This worked for me (Kubuntu 16.04): go to : System Settings->Default Applications->Web Browser and put chromium-browser enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.