Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running ubuntu server 12.04 on VirtualBox.

When connecting via console, I am able to type in Polish characters just fine (both on the command line as well as in VIM).

When connecting via putty, I am unable to type polish chars (AltGr+a produces "a" instead of the polish char)

I would like the system to remain in English however to also be able to type polish characters via ssh.

On putty, under window>translation I set remote char set to UTF-8. I also selected the consoles font with Central European script.

I tried everything I could find on the Internet (installing the polish language pack, dpkg-reconfigure console-setup) but nothing seems to work.

This is what I have for my locale:

LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Thank you very much for all your help!


I figured it out and here is the answer (I can't post it since I don't have enough reputation, spent nearly half a day trying to figure this out and it turned out to be so simple...). Here is the answer:

I fugured it out, thank you very much for all your help nonetheless!

I have win7 and I had my keyboard set to US. I had to go to control panel > region and language > keyboards and languages and add Polish programmer keyboard (adding Polish keyboard but with US layout didn't work). I also set the location to Poland (was US).

This is my work laptop that got rebuilt recently hence I didn't have this set. Polish chars via putty seem to be working perfectly fine now! :)

share|improve this question
1  
While new users can't post answers too fast, they can post them. Would you please post what you did to fix this problem as an answer? I believe you will be able to accept the answer as well in a couple of days, and you should. –  John S Gruber Oct 10 '12 at 22:20
1  
will do John, just trying to figure out how everything works around here :), thanks for the pointers –  dreamwalker Oct 11 '12 at 5:22

2 Answers 2

Do you have the correct locales on the machine? You can find supported locales in by running

$ less /usr/share/i18n/SUPPORTED

Locales mentioned in /var/lib/locales/supported.d/local will be regenerated when running

$ dpkg-reconfigure locales

Otherwise your problem may be your SSH client. If you are using Putty, try the following:

  1. Go to [Connection > Data] and change 'Terminal-type string' to "linux".
  2. Go to [Window > Translation] and change 'Remote character set' to UTF-8.
share|improve this answer
    
I am not sure that this is an issue with locale settings, I tried changing those but this doesn't help, I am still unable to type polish characters via ssh (putty) but even with the locale configuration as posted in the original question above I seem to be able to type those no problem via console (logging in via virtualbox window), any help would be greatly appreciated as I seem to be stuck with this really badly –  dreamwalker Oct 10 '12 at 11:46
    
Updated my answer –  beruic Oct 10 '12 at 11:48
    
I changed the 'Terminal-type string' and already had the 'Remote character set' set to UTF-8 but still getting the same behavior –  dreamwalker Oct 10 '12 at 11:56
    
What characters are we talking about? –  beruic Oct 10 '12 at 12:22
    
śćąłęńóżź, I posted the solution I found in my question –  dreamwalker Oct 10 '12 at 12:23
up vote 3 down vote accepted

I figured it out, thank you very much for all your help nonetheless!

I have Windows 7 and I had my keyboard set to US.

I had to go to Control panelRegion and language > keyboards and languages and add Polish programmer keyboard (adding Polish keyboard but with US layout didn't work). I also set the location to Poland (was US).

This is my work laptop that got rebuilt recently hence I didn't have this set. Polish chars via putty seem to be working perfectly fine now! :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.