Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12.04.1 LTS in my computer with 2 monitors, but when I open "Displays", just one is shown.

Im running a NVIDIA card.

If you need anymore information, tell me and Ill add it.

What am I missing?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

You will need to install the NVidia drivers, if you have not already. You should be able to find these under System Settings -> Additional Drivers -> NVIDIA accelerated graphics driver (version current).

Unfortunately, the NVidia binary drivers do not fully stick to standards for describing multiple monitors. The System Settings -> Display window will show only a single large "screen" spanning both monitors. To configure your dual monitors, you need to use the NVidia X Server Settings tool which should have been installed along with the drivers.

share|improve this answer
    
Simple as that! thanks! –  Dbugger Oct 10 '12 at 10:18
    
maybe its going offtopic, but how can I remove the "sticky edges" if I cant use the "Display" window? –  Dbugger Oct 10 '12 at 11:02
add comment

Essentially this fix should solve the Dual screen not recognized problem. It did for me.

Symptoms I was encountering were:

sudo /usr/lib/nux/unity_support_test -p
Error: no composite extension.

Additionally when I attempted to open the Displays setting dialog, it would error saying something about RANDR and then never open even crashing Ubuntu a few times presenting the reporting dialog.

Some back story: I have an nVidia GeForce 8800GTS. When I booted the LiveCD of 12.04LTS 32bit, it booted with a fancy high-resolution grub, high resolution text mode, and right into unity with full 3D. After a while, ubuntu told me about proprietary drivers I should install, so I did. I installed the [recommended] one but upon rebooting, unity was stuck in 2D mode. So began my search for the fix.

I had been fighting with this issue for the past few days and successfully got unity running in 3D again by doing the following steps:

What I did to fix it:

  1. Get the latest nVidia drivers:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get dist-upgrade
  1. Modify grub to pass in nomodeset (this in combination with #3 did it I think)
sudo nano /etc/default/grub (and uncomment the GRUB_GFXMODE)
GRUB_GFXMODE=1680x1050    

sudo nano /boot/grub/grub.cfg
linux /boot/vmlinuz-3.2.0-32-generic-pae root=UUID=a9aa4a63-ac9c-4fc4-96d8-7861d155d376 ro   quiet splash $vt_handoff nomodeset   
sudo update-grub
  1. Force nvidia-xconfig to run for composite.
sudo service stop lightdm     
sudo nvidia-xconfig --composite   
sudo service start lightdm

So, in all I think it was step 1, and 3 that fixed this for me. Step 2 just made the boot graphics high-res and gave me the super fine text mode I had on my install.

edit

To solve the dual displays issue, I was encountering and giving me access to the Displays settings, I had to stop using xinerama and switch to using Twinview in the nvidia-settings program.

I erroneously thought this would clone/mirror the displays and was using xinerama instead thinking that was the only way I could get both displays to work, but TwinView does exactly what I want; and because I'm no longer using xinerama, Ubuntu Display settings dialog does open (before it was showing RANDR error) and shows two displays.

share|improve this answer
    
Is this answer intended to address the question above? You might be better off asking and answering a new question yourself if you'd like to share this information. –  Mark Paskal Oct 15 '12 at 7:00
    
Yes, my answer is intended to address the question above. It answers a little bit more than just that question, which I hope someone may find useful. I've made edits to clarify these things. Thank you for giving me the advice though as it reminded me I left out the TwinView step in what I did to get this to work. –  grymmjack Oct 15 '12 at 11:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.