Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to prevent installation of lower version of the package over higher version using dpkg.

share|improve this question
add comment

1 Answer

dpkg has option --refuse-downgrade which will do just that.

(The apt tools have a different, more complex mechanism for managing version preferences, which resides in /etc/apt/preferences and /etc/apt/preferences.d.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.