Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a http://domain/ . The LAMP installation guide on the ubuntu site is incredibly easy to follow and I have only experienced my issue this one time...

when I navigate to domain/phpmyadmin I'm getting my sites homepage. My .htaccess file has ErrorDocument 404 / which is redirecting it. I'm not sure what I should check to fix this. Like I said, I've never had any problems until this installation - my .htaccess + phpmyadmin never gave me a problem before.

I've tried reinstalling phpmyadmin using synaptic package manager, which usually fixes these weird missing file situations.

Any suggestions? let me know if you need more info..

Thanks!

share|improve this question

1 Answer 1

Have you checked the Apache configuration file that defines virtual hosts? I'm pretty sure it's normally accessed at /etc/apache2/sites-enabled/000-default (I say pretty sure, because this is normally a link to ../sites-available/default, and sometimes people change these files around a little).

First, I'd look more closely at .htaccess (something I'm not as knowledgeable about as I'd like to be). But you might try substituting a vanilla .htaccess temporarily to see if that makes it work to confirm whether it is the culprit. Or you can just temporarily rename it to disable it.

If you find this is the culprit, then disabling individual lines one at a time should narrow it down to something tangible.

I'd next look for an entry for phpmyadmin, possibly for a "VirtualHost" entry for it with a Directory entry to domain. Normally, phpmyadmin isn't in this file, though.

I don't think there's anything about phpmyadmin itself that would cause this. Do other subdirectories of your domain work correctly from a direct URL?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.