Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unable to launch Nautilus. If I launch it from a Terminal, it says:

    nautilus: error while loading shared libraries: libunity-protocol-private.so.0: cannot open shared object file: No such file or directory

When I LD_PRELOAD this lib, this does work, but I want the solution to be permanent. Does someone has a clue to that ?

Thanks.

share|improve this question

3 Answers 3

See if re-installing will re-configure Nautilus to work correctly:

sudo apt-get --reinstall install nautilus
share|improve this answer
up vote 1 down vote accepted

Fixed !

I encountered many problems with unity, so I typed

    sudo unity --distro

And it solved all my problems.

Thanks anyway!

Edit: The unity usage says to run this option as a sudo, that's why I did it

share|improve this answer
    
Because I read the usage: unity --help –  user95673 Oct 12 '12 at 15:40
    
Right then. Upvoted the answer instead. –  jokerdino Oct 12 '12 at 15:51

Reinstall libunity will fix your problem

sudo apt-get --reinstall install libunity9
share|improve this answer
1  
I tried this, still the same problem... –  user95673 Oct 10 '12 at 12:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.