Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 x64. Orginal Canon drivers are only for 32-bit version.

How can I install this printer in 64-bit version ?

Arkadius



HERE IS SOLUTION


I looked for solution some time and finally found it.

First I try to do it by adding repository like it is written here:
http://www.iheartubuntu.com/2012/02/install-canon-printer-for-ubuntu-linux.html

BUT it did NOT work.
Printer was installed but every print JOB goes somewhere
( probably to /dev/null :) )

Also installing
sudo apt-get install ia32-libs
did NOT worked (it was already installed)

Finally I found solution.

NOTE
I did NOT use orginal Canon drivers for 32-bit.
I also removed drivers from repository:
ppa:michael-gruz/canon

I found solution almost at the end of this thread:
http://ubuntuforums.org/showthread.php?t=1967725&page=10
Most important hint was found in Response #97
"Do NOT install any PPA"

I did as follows:

  • Removed all copies of my printer
  • Removed Canon drivers from repository
    ppa:michael-gruz/canon

    sudo apt-get remove cnijfilter*

  • Added new repository and installed CUPS for Canon:

    sudo apt-add-repository ppa:robbiew/cups-bjnp
    sudo apt-get update
    sudo apt-get install cups-bjnp

  • Installed Gutenprint:

    sudo apt-get install printer-driver-gutenprint

  • Restarted CUPS:

    sudo restart cups

  • Add myself to group lp:

    sudo usermod -G lp -a your_user_name

  • Added printer usings steps from link above:

    Don't install any PPA for the drivers.
    Click the Cog up in the right-hand corner and select Printers.
    Turn on the printer and > make sure it is connected.
    When the Printers windows appears, click +Add and wait a few minutes.
    Your printer should appear within the configuration wizard.
    Mine did and its an Canon MX330.
    Click the defaults and continue on. Cups should identify your printer.
    I saw a few other models in the list.
    I was able to successfully print a test page afterwards.

I hope this will also help someone else.

Arkadius

.

share|improve this question
1  
You should post the solution as an answer to your your own question and not in the question itself. –  Joren Jul 27 '13 at 22:18
add comment

4 Answers

I ran into the same issue and I found out that installing a similar version printer driver has the same driver. Try and find a driver that has a similar version and see if the driver works.

share|improve this answer
add comment

Does that link here not help you?

Canon MP 610 - 64 bit - on Ubuntu

In short you need these packages:

sudo apt-get install ia32-libs cups libcups2 libcups2-dev build-essential

Then you take the original 32 bit driver. You need to download from orig. webside. You unpack this file and find three files:

cnijfilter-common_2.80-1_i386.deb
 cnijfilter-mp610series_2.80-1_i386.deb
cnijfilter-common-2.80-1.tar

You install now with the following commandSSS:

sudo dpkg -i --force-architecture --ignore-depends=libcupsys2 cnijfilter-common_2.80-1_i386.deb

sudo dpkg -i --force-architecture --ignore-depends=libcupsys2 cnijfilter-mp610series_2.80-1_i386.deb

Then restart cups:

sudo /etc/init.d/cups restart

Then do a test:

5 Simple Steps to Setup the Canon MP610 Printer and Print a test page.

From the Ubuntu Desktop Menubar, Select:
System | Administration | Printing
Select Add to add a printer.
Select Canon MP610 when prompted for a device.
The Installer will attempt to locate a driver for the printer.  This may take a few minutes.
A dialog box containing details of the printer will be presented.  Select:
Apply
You will then be asked if you wish to print a test page.  Select:
Yes.

Congratulations!!! You may now print using the Canon MP610 printer.

share|improve this answer
    
Thanks for fast answer. But your solution is NOT working. My print JOB is in state STOPPED. When I check attributes I see that "JOB-PRINTER-STATE-MESSAGE: /usr/lib/cups/filter/pstocanonij FAILED" –  Arkadius Oct 9 '12 at 22:33
    
Also I can NOT do anything with apt-get because I get errors: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: cnijfilter-common:i386 : Depends: libcupsys2:i386 (>= 1.2.1) Depends: libpopt0:i386 (>= 1.7) but it is not going to be installed cnijfilter-mp610series:i386 : Depends: libcupsys2:i386 (>= 1.2.1) [ ... CUT ... ] E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). –  Arkadius Oct 9 '12 at 22:35
add comment

In Ubuntu 13.04 64bit I only had to install the package cups-backend-bjnp to get the Canon MP610 working. There's no need to add third-party PPA's in Ubuntu 13.04.

  1. sudo apt-get install cups-backend-bjnp
  2. sudo restart cups

Now the printer would be automatically detected as "Canon PIXMA MP610". For some reason it will display the "Searching for drivers" dialog, but you can just hit Cancel. It had already automatically found the right driver from the driver database in my case.

Clicking the Print Test Page button successfully prints a test page with colors.

share|improve this answer
add comment

What worked for me:

  1. Installed cups
  2. Started printers via launcher
  3. Selected my printer and clicked on forward

  4. While being stuck on the install dialog, I killed dpkg via

    ps ax | grep dpkg
    sudo kill <nr-of-dpkg-process>
    sudo dpkg --configure -a
    
  5. Then was able to select the driver and install it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.