Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Thunderbird on Ubuntu 12.04 and every time I open it, it loads twice. Two windows are opened.

To be clear, if I have Thunderbird closed (not minimized) and click on Mail, in the tray bar, it opens 2 main windows.

I have had installed several add-ons, including FireTray and "Minimize to Tray Revived", but now I have removed all of them. Actually I can disable all the add-ons and it still happening.

Any ideas?

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

Follow these steps:

  1. Disable "MinimizeToTray Plus" in menu "Tools/Add-Ons/"
  2. Exit Thunderbird (Be sure that the process is not running)
  3. Open Thunderbird (In my case, I had the same two windows problem the first time)
  4. Now Thunderbird runs without the MinimizeToTray Plus add-on.
  5. Close one of the window.
  6. Re-enable your "MinimizeToTray Plus" add-on 7. Exit and restart

From this forum thread: http://forums.mozillazine.org/viewtopic.php?f=39&t=1962329

share|improve this answer
    
Thanks! It worked. Steps reproduced here: 1. Disable "MinimizeToTray Plus" in menu "Tools/Add-Ons/" 2. Exit Thunderbird (Be sure that the process is not running) 3. Open Thunderbird (In my case, I had the same two windows problem the first time) 4. Now Thunderbird runs without the MinimizeToTray Plus add-on. 5. Close one of the window. 6. Re-enable your "MinimizeToTray Plus" add-on 7. Exit and restart –  Diego Jancic Dec 4 '12 at 15:04
add comment

I had the same on one of the machine I manage and the solution was pretty simple in the end. On one of the two windows just do file->Close. It closes just that window and not the other. Then close TB and reopen it.

I've seen quite a lot of mention of problems with add-ons, but in this case there were none and none of the other solutions worked.

Ian

share|improve this answer
add comment

In preferences of FireTray (my version is 0.4.8) please check the field:

[] Only last window can be hidden

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.