Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Windows server 2008 on Ubuntu server 12.04.1 via devstack and I am trying to download a file from an ftp server using the windows command line ftp client.

When I run the ftp get command I get the following error message:

500 I won't open a connection to 10.0.0.2 (only to XX.XX.XX.XX)
425 No data connection

10.0.0.2 is the internal IP address of the instance, whereas XX.XX.XX.XX is the external address. Is there anyway to make the ftp client use the external address for the data connection, or alternatively have the client establish the connection?

Thanks

share|improve this question
add comment

1 Answer

I believe that you want to use Passive FTP. For some reason it's not a command line option anymore. Go to:

Control Panel, Internet Options, Advanced, Browser Options section, Use passive FTP

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.