Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using NoMachine to access Ubuntu 11.10 when suddenly the internet on Ubuntu stopped working. Now Ubuntu doesn't recognize the internet at all (including locally).

Symptoms:

  • Doesn't recognize the fact that there is an ethernet cable attached. (I've tried switching cables, didn't work.) GUI says "No network devices available"
  • Can't ping external IP addresses.

  • Tried changing /etc/network/interfaces to eth1 instead of eth0 but it didn't work.

  • ifconfig provides no output relating to eth0.

  • When I type "/etc/init.d/networking restart" it tells me "Cannot find device 'eth0'/Failed to bring up eth0."

The network settings had used a static IP address prior to the crash. I don't know why it won't recognize the ethernet (I think this is the fundamental problem, but I might be wrong) and why it stopped working so suddenly--I haven't installed any updates lately.

Any ideas? Any more information I should provide?

EDIT:

lspci recognizes the Ethernet controller; netstat does not. lspci calls it "Intel Corporation Device 0000". I'm not sure what this is SUPPOSED to be, because it seems kind of generic and that might mean it's corrupted--does anyone have any experience with corrupted ethernet cards?

share|improve this question

closed as too localized by Marco Ceppi Nov 13 '12 at 14:58

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
How were you aware that the Internet was gone ? And what did you do several minutes before that ? –  NorTicUs Oct 9 '12 at 19:15
    
I was running a simulation in C--it was pretty memory intensive. I was aware it was gone when NoMachine gave me a message that the connection was lost. When I went over to the machine, it wasn't responding and I had to restart it. Once it restarted I could tell that the internet wasn't working locally (it didn't recognize any network devices). –  user95629 Oct 9 '12 at 19:18
    
I would suggest a cable issue, but btw the output of "dmesg" could maybe help : there are still buggy network drivers in ubuntu (e.g. Atheros), the driver crashes, then internet disappears (and could also crash again after reboot). On top of that, eth0 status is probably logged there. –  JB. Oct 9 '12 at 19:50
    
dmesg doesn't say anything about "eth0", does that mean my network card isn't being recognized? Is there something else I should be looking for in the output? –  user95629 Oct 9 '12 at 20:47
    
I'm pretty sure it's not a cable issue; it's connected in the same places as it was when it was working, and I replaced the ethernet cable and nothing changed. –  user95629 Oct 9 '12 at 20:51
add comment

1 Answer 1

Accidentally fixed the problem! Restarting the computer didn't work, but after I unplugged the computer, plugging it back in and turning it on again fixed the problem.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.