Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I regularly set up Virtualbox ubuntu setups to run as local webservers. I have set these up several times and never had an issue. However, something has changed:

1)VB guest additions no longer allow me to copy and paste (I'll worry about that later)

2)More importantly phpmyadmin no longer works as installed - Initially going to localhost/phpmyadmin gave a message that the page could not be found. So I have followed some instructions which told me to do the following in var/www:

sudo ln -s /usr/share/phpmyadmin phpmyadmin

which has created a phpmyadmin directory in /var/www but now I get an error saying:

the mysqli extension is missing.

If I run phpinfo mysql and mysqli are listed.

All I have done so far is

sudo apt-get update  
sudo apt-get install apache2
sudo apt-get install php5
sudo apt-get install mysql-server

and

sudo apt-get install phpmyadmin 

I found a post of a similar question which suggested I should do

sudo apt-get install php5-mysql

(I've done this) and edit php.ini and uncomment the line:

extension=mysqli.so

This is not there, so I tried adding it but no joy. I have restarted apache and still no phpmyadmin.

I'm running a windows 7 machine and the guest os is ubuntu 12.04

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Ok I have found the answer to this.

Dont do this step (not needed):

sudo ln -s /usr/share/phpmyadmin phpmyadmin

Dont do this step (not needed):

edit php.ini and uncomment the line:

extension=mysqli.so

Do do this:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf

Apparently this serves to "symlink the phpMyAdmin conf file within the apache2/conf.d/" courtesy of pete fisher: http://blog.peterfisher.me.uk/2012/06/27/solution-to-phpmyadmin-throwing-a-404-error/

share|improve this answer
add comment

For ubuntu 13.04 I moved the phpmyadmin conf file to the enabled conf files of apache to get it working.

Do this:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-enabled/phpmyadmin.conf

Restart apache to get everything working.

Do:

sudo service apache2 restart or sudo /etc/init.d/apache2 restart

Happy coding

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.