Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to access an SVN repo hosted on a Windows machine from Ubuntu. However, even if I supply the proper credentials, it denies me access, apparently because Windows does not allow Linux connections (as they told me); sure enough, I got in when I tried to checkout from my XP partition. While I have my box dual-booted, it is inconvenient to switch just for SVN.

So, does anyone know how I can access that SVN repo from Ubuntu? I've tried installing TortoiseSVN and Windows Subversion under Wine but I can't even get them to run; they were asking for some DLLs that I don't know how to supply. I've thought of installing a virtual XP just for SVN but I consider that too extreme and I'd be glad if anyone can advise a simpler workaround.

Hopefully-relevant note: When I access the repo on Windows, I use the prefix file://; svn:// and https:// results to an error. (So, AFAIK, I'm accessing the repo via our LAN.)

share|improve this question
    
There is no need to install windows tools for Subversion with Wine. –  BuZZ-dEE Oct 9 '12 at 15:28
    
"...because Windows does not allow Linux connections (as they told me)" Who told you that? –  BuZZ-dEE Oct 9 '12 at 15:30
    
Been told from coworkers who have been using Linux at work longer than me. They're from another team and they told me they migrated their SVN server from Linux when they switched as well. –  skytreader Oct 10 '12 at 1:00
    
pls pass this link to whoever is incharge of maintaining your server, hopefully it will convince them to switch before $#!+ hits the fan –  Karthik T Oct 10 '12 at 1:14

2 Answers 2

up vote 1 down vote accepted

I am not aware of any such restriction. My previous job used a SVN repository hosted on a Windows server and accessed by mostly Ubuntu clients using the commandline svn that came with it. It was hosted via https:// and not svn:// but that should not matter either.

Can you be more specific on what happens when it denies you access?

Do you have any info on which server is used to host the repository? My previous job used Visual SVN

p.s. some more confirmation from more authoritative sources

share|improve this answer
    
Well, this might be the thing; you see, when I'm accessing the repo at Windows, the prefix I use is file://. I've mistakenly tried using the svn prefix once and got an error. –  skytreader Oct 10 '12 at 1:01
1  
file://? thats weird.. that protocol is meant to be used only if your repository and working copy is on the same machine afaik.. unless the repo is hosted via file sharing.. which sounds like a bad idea..... Some more info from authoritative sources –  Karthik T Oct 10 '12 at 1:11
    
Wow. Thanks for that link. I'd be sure to relay that. But for the meantime, are you aware of how I can workaround this? file:// does not seem compatible when host is Windows and client is on Linux (unless I misunderstand). Or am I left with no choice till we're not using file:// anymore? –  skytreader Oct 10 '12 at 5:46
    
Im sorry, I have no workarounds for you since im still not sure why it doesnt work for you. This Link seems to prove that it is indeed possible to connect to a svnfile:// repository that is hosted via samba at least.. close but no cigar perhaps. It also gives you yet another warning against this style of usage. –  Karthik T Oct 10 '12 at 10:52
    
Oh well...guess I'd just have to persuade better and faster. Thanks for your help. –  skytreader Oct 10 '12 at 14:37

You can install Subversion Install Subversion via terminal Ctrl Alt T.:

sudo apt-get install subversion

Now you can checkout the repository (example).:

svn checkout http://localhost/svn/projekt1/trunk/ /home/user/projekt1

Subversion example image

See: Subversion @ help.ubuntu.com and TortoiseSVN (Subversion Client)?

share|improve this answer
    
+1 Great answer, short and straight forward! –  cauon Oct 9 '12 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.