Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I press any button 2 times quickly (I mean with less one second of delay between the keystrokes), Ubuntu doesn't detect the second one. In particularly, Ubuntu seems to detect the pressure because when I push the backspace, I can listen the sound related to the beating, but it has no effect (the letter is not inserted in the text or deleted in backspace case). How to fix it?

Note: I used Ubuntu 11.10

share|improve this question
1  
Maybe it is an issue with your keyboard. Did you check that with a different device or OS? –  cauon Oct 9 '12 at 14:57
1  
Yes I checked and my keyboard is OK:if I run another OS or merely I start a console without X activated (pressing CTRL+ALT+F1) it works properly. It's really strange issue. –  aldo85ita Oct 9 '12 at 15:28
    
You could try the following: manpages.ubuntu.com/manpages/lucid/man8/kbdrate.8.html There you can set the repeat spead that you have with your keyboard. Another way would be to set in bios if possible. But you said that it works in other os - so I would stick to my first link. –  Peterling Oct 9 '12 at 20:43
    
Hi @Peterling, thank you for your help. I tried to set rate= 10.9cps and delay= 250ms and also delay=100ms and rate=30' but the problem still exists. Have you got any other idea? –  aldo85ita Oct 10 '12 at 21:41
    
Can I reinstall all system files related to keyboard? –  aldo85ita Oct 27 '12 at 10:02
add comment

2 Answers 2

up vote 2 down vote accepted

I had the same problem. Its with the key board.

This is called filter keys. you have to uncheck this function, this function does not recognize multiple strikes of same key in continuance.

Press shift 5 times, you will either 1) get a window of sticky keys. press 'settings'and uncheck filter keys or, 2) see a small clock on the lower right hand side of your screen, click on that and it will open sticky keys window and rest follow the same as in 1). and you are done :)

Let me know if it helps !! :)

share|improve this answer
    
Thanks @mneeti, you're answer has been very useful. if I press shift 5 times, nothing appears but, I find the solution: It's not "sticky keys" enabled, but "Bounce Keys"! I'll post the screenshot that show how to fix the problem. Than you very much again. –  aldo85ita Nov 16 '12 at 10:59
1  
@aldo85ita, if this answer solved your problem you should accept it by clicking the tick on the left side of the answer, this will give mneeti and you points –  ecoologic Nov 16 '12 at 11:14
add comment

To fix the problem disable "Bounce keys" showed in the following image: show image

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.