Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have never used a Linux system in an AD environment before and am trying to join my laptop running Ubuntu to join our Active Directory (DC is a Windows Server 2008 machine) using Likewise-open.

  • Using the GUI wizard, I have joined the domain.
  • I can mount network shares using CIFS

My fstab entry looks like this:

//server/share  /mnt/foo    cifs    auto,iocharset=utf8,rw,credentials=/home/aron/.smbcredentials   0   0

Problem:
I only have read access to our fileserver. What more is needed to get the AD to recognize me as a user who has the appropriate rights?

Any help is appreciated.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I finally solved the problem.

It turned out, this would not work without a valid GID or UID parameter in fstab.

I added my UID to the fstab entry and I can now write the share perfectly.

This resource has helped me come to this conclusion.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.