Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

my laptop is lenovo g580. Configuration is CPU : Intel® Core™ i3-2370M CPU @ 2.40GHz × 4 GPU : Nvidia geforce 610M Kernel Linux 3.5.0-17-generic

My problem is that I cannot control the screen brightness. When I try to control the brightness using (Fn + up/down) the pop-up notification on the right top of the screen comes but the brightness does not change.

When I installed ubuntu for the first time the brightness control worked properly. But after the first reboot brightness not changing. Then I installed kernel 3.5. After that also the brightness control worked properly. But after the first reboot brightness not changing.

Now I observed that brightness control works well after the very first reboot of kernel update (update-initramfs -u).

What may be the reason? Thanks in advance.

share|improve this question

marked as duplicate by karel, BuZZ-dEE, mikewhatever, Eric Carvalho, Alvar Jan 12 '14 at 22:54

This question was marked as an exact duplicate of an existing question.

Welcome to askubuntu! I suggest checking this thread. There seem to be some solutions posted. If you found an answer there that fits your question, please post and accept your answer here. Thanks and good luck! – cauon Oct 9 '12 at 8:52
This appears to be the same question that you posted previously. Assuming that's the case, you should edit your question, rather than posting a new one, when you have more information to provide. Ask Ubuntu works best when work on the same problem is not scattered between multiple questions. Welcome, and good luck! – Eliah Kagan Dec 27 '12 at 23:46

Even I had the same problem. For brightness control edit the grub.cfg file like given below and reboot. Now u will be able to use the keys. Note: the code you need to edit is highlighted.

menuentry 'Linux Mint 13 Cinnamon 64-bit, 3.2.0-23-generic (/dev/sda6)' --class linuxmint --class gnu-linux --class gnu --class os {
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos6)'
    search --no-floppy --fs-uuid --set=root 193c42e2-847f-42e9-9798-bca4c2b9597d
    linux   /vmlinuz-3.2.0-23-generic root=UUID=6304e339-3f61-4aac-be29-fbf7a252b37f ro **acpi_backlight=vendor**
    initrd  /initrd.img-3.2.0-23-generic
share|improve this answer
Unfortunately there is problem with the nVidia graphics drivers for GT 610M in linux. Currently none of the drivers works. U can not use them for display manager, u will loose the existing display manager otherwise. – Suhas D Heeraskar Oct 29 '12 at 9:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.