Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm kinda new on this, and need some help. I had MC on my windows with mods, when changing to Ubuntu I got the same version. I tried to install the mods I had on my windows but I cannot make it work, because there's no .minecraft file nor %appdata%. I followed instructions like copying modloader into the .jar file, which didn't work and other stuff Can you help me, please?

share|improve this question
Follow the directions below but also when installing mods, either follow a Linux directions list or Mac directions, the process for both Mac and Linux are relatively the same. – Weylin Schreck Oct 9 '12 at 3:06

Ubuntu shows folders a bit differently, and organizes them in a different fashion.

Open your home folder. Press Ctrl+H. You should now see it as "dot-folders" are usually hidden. This assumes you have run minecraft as your user previously. If you haven't, run it, doing a few things in it(just to get it to create its config files).

share|improve this answer
I've done it, and I found one, but the Windows one (I've got all the files for Windows, MAC and Ubuntu) the .jar inside is the same as the one I run for playing normally. I just tried pasting the mods in it, modifying it, and it doesn't run. Running the other file, runs with no mods. D: I must be doing something wrong... – Alexander Holman Oct 9 '12 at 3:32
I don't really work with Minecraft, but I'll ask some acquaintances about this. – hexafraction Oct 9 '12 at 10:27

It's very simple to access it.

Open up Minecraft. If you haven't logged in yet, then do so, the at a corner of the window press the button that says "Edit Profile".

Then there's a button at the bottom that says "Open Game Dir" which will open the .minecraft folder you're looking for.

That's all there is to it.

share|improve this answer

it actually is not called %APPDATA% It is actually called mods if you installed forge to access it you go to resource packs and open the file to put them in but then you go back a file (you will see it in the corner of the window) it is called .minecraft look in there AFTER you installed forge it will be there!;)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.