Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I currently have my desktop PC dual booting Windows 7 and Ubuntu. The PC has a wireless card installed. I run a LAN cable from the PC to my Xbox 360. In Windows 7, I can bridge the wireless and wired connections so that my Xbox gets an internet connection and its own IP address. From my router, I can then open ports to my Xbox that it needs.

When I boot into Ubuntu, however, I run into issues. I have the wired connection set to "Shared to other computers" under IPv4 settings as it should be. The Xbox then has internet connection. Instead of having a 192.x.x.x IP address which I could open ports to, however, it is given a 10.x.x.x address. My router won't allow me to open ports to this address since it's on a separate subnet.

Here's the question:

How can I change the connection share so that it keeps my Xbox on the same subnet?

share|improve this question

1 Answer 1

In graphical way u can try this link

http://www.howtogeek.com/116409/how-to-turn-your-ubuntu-laptop-into-a-wireless-access-point/

from command prompt try below

Hi you need to configure hostapd

I have configure following in hostapd /etc/hostapd/hostapd.conf with WPA authentication options for wireless users

01 interface=wlan0

02 driver=nl80211

03 ssid=dontMessWithVincentValentine

04 hw_mode=g

05 channel=6

06 macaddr_acl=0

07 auth_algs=1

08 ignore_broadcast_ssid=0

09 wpa=3

10 wpa_passphrase=KeePGuessinG

11 wpa_key_mgmt=WPA-PSK

12 wpa_pairwise=TKIP

13 rsn_pairwise=CCMP

sudo hostapd /etc/hostapd/hostapd.conf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.