Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This question already has an answer here:

The screen of my laptop (Dell Vostro 3460) supports 16 levels of brightness: Not only according to the manufacturer, but also as is clear from two OSs: Both Windows 7 and Ubuntu (dual-booted) support all levels. On Windows 7, the hotkeys for brightness adjustment support all levels.

In ubuntu it is apparent when going on the brightness slidebar (see picture below) from left to right; I can count 16 different levels of brightness when doing so.

The brightness slider of ubuntu

When using the hotkeys (Fn+F4 and Fn+F4), however, only 5 levels are supported. How can I adjust these levels and make them in line with what my screen supports?

share|improve this question

marked as duplicate by karel, Eric Carvalho, Warren Hill, Maythux, Paranoid Panda Jul 22 at 13:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Do the Fn+F4 keys work when your screen is locked (password prompt), but turned on? I have the same problem on my System76 Pangolin Performance laptop. It seems that GNOME is grabbing the brightness keys and doubling the brightness change. When my screen is locked and showing the password prompt, the Fn+F5 and Fn+F6 brightness keys work normally, minus the on-screen notification. –  Shane Oct 20 '12 at 3:42
    
That's weird. Indeed when the screen is locked the steps taken are smaller (yet not as many as in my screen supports). This obviously is a bug, but of what package, and where to report? –  Koen Oct 20 '12 at 12:27
    
Almost same problem here in my Vostro 3460. I cannot change screen brightness. No levels detected. I've tested through Brightness & Lock settings and through Fn+F4/F5 keys. –  HGF Jul 4 '13 at 14:15
    
Some other potential solutions may be found here: askubuntu.com/questions/128463/how-to-control-brightness –  Koen Sep 27 '13 at 12:34
    
Or here. Do any of these answers solve your problem? By the way it may be what Shane is suggesting in that the DE is choosing which levels to go for. –  Wilf Aug 16 at 9:44

2 Answers 2

While the question is a little different to your question, I found a possible cure when answering this question Cannot change brightness

After I had completed this, I found that I had the full numbers of steps that I was looking for, rather than the 4 I was being given before.

Basically:

  1. Open Terminal with Ctrl + Alt + T
  2. I typed in sudo gedit /etc/default/grub, entered my password
  3. I changed the line which read

    • GRUB_CMDLINE_LINUX="" to
    • GRUB_CMDLINE_LINUX="acpi_backlight=vendor" (Note: not the vendors name)
  4. Saved and Closed gedit.
  5. in Terminal I updated the Grub with sudo update-grub
  6. I re-booted the laptop
share|improve this answer
1  
before I'll try and nuke my system: I think 'vendor' should be replaced by a vendor? In that case; how can I find out what I should fill in? –  Koen Sep 15 '13 at 15:16
1  
No, I added the line as entered above. –  SimplySimon Sep 17 '13 at 9:34
    
Thanks for the clarification. Note: it did increase my levels from 5 to 7 (plus no backlight). However, this is not up to the amount of levels on the login-screen. Additionally, it breaks launchpad.net/indicator-brightness –  Koen Sep 27 '13 at 12:24

Same solution as one-liner

For this solution no nano knowledge is required. It is also handy for multi-machine installation scripts.

sudo sed -i 's|^GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"|GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"|' /etc/default/grub && sudo update-grub
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.