Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I do a single click, my computer (with Ubuntu 12.04) acts like it was double click. I think it happens in ~50% of cases.

It happens with all the program I use: browsers, file manager, terminal and so on. I'm not sure when exactly it started, maybe a week ago, and I don't remember if it started to happen after system-update or after the installation of some packages.

What I tried:

  • change mouse
  • change mouse settings like Double-Click Timeout

None of those helped me. Any ideas?


UPDATE

This bug has disappeared after upgrading to 12.10.

share|improve this question
3  
This might be this open bug: [bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/… –  phoibos Oct 10 '12 at 18:02
    
Does it happen if you use live Ubuntu installation CD? –  nastys Oct 11 '12 at 10:02
    
You can also make sure that it's not a hardware failure by simply trying out another mouse. –  zerwas Oct 14 '12 at 20:12
    
just ran into the same issue - had a dell mouse for a desktop PC; replaced it - and the fun was over –  Grigorash Vasilij Feb 8 '13 at 5:41

2 Answers 2

up vote 2 down vote accepted

If you've manually edited xorg.conf, try adding and entry for your mouse, in case it was somehow deleted:

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Source: http://ubuntuforums.org/showthread.php?t=1844513&page=2

EDIT As mention in the comments, this seems to be a reported bug that has stood for some time now. It may be best to add your info to Launchpad to help resolve the bug in the future.

share|improve this answer
    
Thanks for the answer, I added this section to xorg.conf but it didn't help :( –  evfwcqcg Oct 10 '12 at 18:19
    
I copied and pasted straight from the forum, so you may want to check the settings I've provided to match what you have. –  Kyle Macey Oct 10 '12 at 18:37

I had the same happen to me for no apparent reason a few days ago on 12.04. I went to nautilus Preferences..Behaviour and it had "Double click" option selected. I then selected single click, checked that was working, then went back and changed to double click again and bingo! Its back in double click mode!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.