Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung series 5 ultra (np530U4c - ivy bridge/Nvidia version).

The machine won't suspend on lid closing.

I has worked on fresh install. After it I added "pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1" to grub defaults.

After It the suspen not worked anymore. ...Neither with extra params nor without them.

I think the kernel switched off the lid closing detection, because it won't work on windows too.

How can i fix this?


My laptop bricked and the service changed the mother board so I got this problem twice.

share|improve this question

1 Answer 1

These kernel bug reports are related to your issue:

https://bugzilla.kernel.org/show_bug.cgi?id=44161

https://bugzilla.kernel.org/show_bug.cgi?id=45461

According to the information in those reports, you can temporarily fix your problem by doing the following:

  1. Power the computer down
  2. Remove AC plug
  3. Cut the battery power (it's a small hole on the bottom of the device, hold pressed for 5-10 seconds)
  4. Plug AC power in before you power the device on

However, the problem will return next time you boot Ubuntu until those bugs are fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.