Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

My first time trying to use Ubuntu. I clean installed the Ubuntu 12.10-beta2 on an old Dell Dimension 4600 today. Install seemed to go fine, but after restarting and entering the requested passwords I'm taken to a purple screen with no panels, launchers or anything else--just a purple screen. I'm able to access the terminal from the screen with ctrl-alt-t, but I'm not sure at this point in my Linux training how to search for errors. Also have no Internet connection (I'm typing this on a mac), but I'll have to deal with that later. Would appreciate any suggestions.

share|improve this question
    
I ran the tail -f /var/log/syslog command at kmassada's suggestion and it seems to be riddled with hundreds of errors. I installed from a usb flash drive, not sure if that's part of the problem. Would you suggest reinstalling the beta version or perhaps try a different one? Thanks again! –  Gene Oct 8 '12 at 15:31
add comment

marked as duplicate by karel, Avinash Raj, Aditya, mikewhatever, minerz029 Jan 25 at 21:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers

Those are the symptoms of bug 1039155, which was marked fixed by an update in Quantal today. Update and try it.

compiz (1:0.9.8.4-0ubuntu2) quantal; urgency=low

  • debian/patches/unity_support_test.patch:

    • force llvmpipe in the unity profile if we are in the grey zone, meaning: the card and drivers have opengl support, however, it doesn't met unity requirements (opengl < 1.4, no vertex shaders support…). Thanks duflu (LP: #1039155)

      Note that we already discourage them to upgrade from precise to quantal with a warning before the upgrade, however let's get a slow ui rather than none on the iso as well.

    -- Didier Roche Tue, 09 Oct 2012 15:26:52 +0200

Update: the user who filed that bug has written: "Re-opening the bug as it is not fixed for me." So this looks up in the air for now.

share|improve this answer
    
Thanks very much for letting me know about that Ed! –  Gene Oct 10 '12 at 20:23
    
Sure. :) If you find out, let us know whether the update helped much! –  Ed Donovan Oct 11 '12 at 7:43
add comment

For any errors in ubuntu, usually this command would help pin point if there was a major error. It is a way of viewing a snippet of your error log.

tail -f /var/log/syslog

Also since you can bring up the terminal, my guess is, unity must have an issue. I recommend you run the following commands

first open the software properties window,

sudo software-properties-gtk

go to other software TAB, and enable the Cannonical Partners and the source code, and the independent, and their source code. Also in the Ubuntu Software TAB, enable all the following sources,

If the issue is that you've installed a buggy package, it will upgrade your system, with the latest fixes. Ubuntu repositories talks about each, and what is their role. Since you running beta anyways, i'll recommend it. But you can read up and see if you want to keep them enabled after the final release. Close the window

sudo apt-get update
sudo apt-get upgrade 

reboot.

If error persist, we have to reset unity, from command line

install dconf-tools

sudo apt-get install dconf-tools

Reset Compiz and Unity

dconf reset -f /org/compiz/

setsid unity
share|improve this answer
    
Seems to be riddled with errors. I installed from a usb drive, don't know if that was an issue or not. May be too much info, but here's what I got after running the first command: –  Gene Oct 8 '12 at 15:27
    
I don't get to see your code, if it is pastie.org, just comment with the ID at the end of url. –  kmassada Oct 8 '12 at 15:34
    
pastie.org/5019380 –  Gene Oct 8 '12 at 15:51
    
hmm doesn't look familiar.. must be usb you still have plugged in, did you try the packages upgrade? and reboot? –  kmassada Oct 8 '12 at 16:04
    
Yes, but I can't connect to the internet yet and it looked like it needed a connection to download some of the upgrades. I may be better off uninstalling it and trying over. Do you think I should go with the beta version again? –  Gene Oct 8 '12 at 17:54
show 4 more comments

Sorry, I can't post it as a comment to kmassada answer because of not enough reputation. For me helped

dconf reset -f /org/compiz/

setsid unity

but only when run it from a unity terminal alt-ctrl-t

share|improve this answer
add comment

Please look at these links: Unity doesn't load, no Launcher, no Dash appears

this one solved my problem (i have Ubuntu 13.10): Unity completely broken after upgrade to 12.10?

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.