Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been looking at other questions, but none seem to answer my query. The closest I got gave me information about a ppa for 12.04. My computer's battery life is suffering under Ubuntu 12.10. I imagine the performance will be better if I use LLVMPipe, as it is aimed at lower end computers. How do I enable LLVMPipe?

I might add that going back to 12.04 is not an option, as my computer only works in Unity 2D, which didn't quite do it for me. As far as I understand, LLVMPipe is pretty much the same as regular Unity. However, I can't seem to find much information about it. If this is wrong, correction would be much appreciated.

share|improve this question
    
This method does not force LLVM software rendering afiak, it only uses the low graphics unity mode that also happens to be used automatically when LLVM rendering is used. With this method you should be able to keep hardware acceleration and get better performance due to the turned off effects, which is even better than forcing software rendering anyway :) –  user115332 Apr 19 '13 at 3:52
add comment

1 Answer

up vote 21 down vote accepted

There is an environment variable you can set, UNITY_LOW_GFX_MODE

Running

UNITY_LOW_GFX_MODE=1 unity 

should replace your existing session with the "low graphics mode" desktop.

If for some reason you want to make it permanent

  • For your user:

    Add the line

    export UNITY_LOW_GFX_MODE=1
    

    to the file ~/.xprofile (create one, if it doesn't exist).

  • Or globally:

    Create a file /etc/X11/Xsession.d/99force-llvm and add above line (requires root permissions, see this answer about how to create a file as root).

    You can set this globally in one step by running the following line inside a terminal:

    echo "export UNITY_LOW_GFX_MODE=1" | sudo tee /etc/X11/Xsession.d/99force-llvm
    
share|improve this answer
    
Thanks a lot :D –  Mr Greeb Oct 17 '12 at 22:01
    
I thought LLVMpipe is an auto-fallback if your machine doesn't support OpenGL? –  Marky Oct 25 '12 at 2:52
    
It is, this forces it if you want to. –  Jorge Castro Oct 25 '12 at 2:58
2  
How can I tell if this is working? I'm having graphical problems that I suspect are related to my video card, but doing this hasn't changed anything. –  namuol Dec 4 '12 at 4:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.