Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have added a network printer, a Konica Minolta C253, via cups by its IP ( under the http://localhost:631/ cups webfrontend on an Ubuntu 11.10 client.

I used the documented KOC353U.ppd in the process.

I was able to print exactly one page.

Afterwards, all I get in the printer's status is the message: "Network host '' is busy; will retry in 30 seconds".

What is the problem here and how do I resolve it?

share|improve this question

don't use ipp.

use "socket://###.###.###.##:port#/" for your printer instead.

port # maybe 9100 or 631

Reason: The first specifications of IPP lacked of some important details. This allowed Microsoft to implement it in a their own way. The result was that printer manufacturer had to decide how to do their IPP support the way Microsoft does.

Therefore you should use a different protocol, the socket protocol.

share|improve this answer
This got me in the right direction. Yet via socket I got a broken pipe error. lpd was the solution that worked for me. – k0pernikus Oct 8 '12 at 10:19
ok, thats good. – user61928 Oct 8 '12 at 10:27
up vote 2 down vote accepted

I solved it by switching to the lpd protocol. Socket lead to a broken pipe problem.

So I changed the connection to:


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.