Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Apache2 and Webmin with my Raspberry Pi. After a restart and reinstallations Apache won't start.

> sudo /etc/init.d/apache2 restart
apache2: Syntax error on line 268 of /etc/apache2/apache2.conf: Could not open configuration file /etc/apache2/sites-enabled/000-default: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
failed!

The file 000-default is there and unopenable permissions to root-root. My apache2.conf file looks like this (bottom half):

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel debug

# Include module configuration:
Include mods-enabled/*.load
Include mods-enabled/*.conf

# Include list of ports to listen on and which to use for name based vhosts
Include ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see the comments above for details.

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/
<VirtualHost *:80>
DocumentRoot /var/www
<Directory /var/www>
allow from all
Options +Indexes
</Directory>
ServerName IMASERVER
</VirtualHost>

Does anyone know what is the cause of this?

share|improve this question

1 Answer 1

Firstly, having VirtualHost(s) inside the config file is a bad move, (I'm not even sure it's possible) the whole idea of sites-enabled is to have your VirtualHosts in different files in that folder, and simply use

a2ensite default
a2dissite 000-default

With this said, you can try remove the VirtualHost-block in your config file and make (or edit) the default file in sites-enabled. Make sure you restart apache.

I assume the file you posted is /<some-dir>/apache2/apache2.conf

However, the file you posted above doesn't look anything like the config files I've seen for apache. Can't help you on that one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.