Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to open Synaptic from the AWN Cardapio applet menu it gives me the 'starting without administrative privileges' message and then I can't install anything.

I can run sudo synaptic and it works fine, but how can I get it to just prompt me for my password like it used to? I don't like having to open terminal just to open synaptic. Any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Since the common user does not have permission to install programs (Since installing programs is an administrative activity) you need to start synaptic as an administrator. To do this you can:

  1. Start synaptic through the menu: System -> Administration -> Synaptic

Or

  1. Press ALT+F2 and type: gksu synaptic (gksu is to start a program in gui as administrator)

If you run it like one would normally would, just typing synaptic, synaptic will run with the privileges that the running user has. Since the privileges of the normal user are not administrative level, synaptic throughs that security message. At that level, you can only see the programs you can install and information related to them, but you can not install from the lack of administrative privileges.

NOTE - If you edit the main menu and go to the synaptic option of the menu, you will see it also starts with gksu. That is why in the menu it works like it should.

share|improve this answer
    
oh ok thank's, i edited the Cardapio applet in AWN to start synaptic with the command you said –  Uri Herrera Jan 2 '11 at 22:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.