Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been looking for a fix, but no luck. my Asus 101mt has a maximum resolution of 1024x768, but I cannot select this in "Displays" since it is not an option.

I have added this resolution before, but now I can't seem to find the same information. I just did a clean install with 12.04. I am also dual booting with Win 7.


I have been trying to get this working for a while and now I switched to 12.10. I tried using xrandr, but this is as far as I get.

barzyk@barzyk-T101MT:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 220mm x 129mm
   1024x600       60.0*+
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

barzyk@barzyk-T101MT:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

barzyk@barzyk-T101MT:~$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

barzyk@barzyk-T101MT:~$ xrandr --addmode LVDS1 1024x768_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  25
  Current serial number in output stream:  26

Any Thoughts?

share|improve this question
    
Dou you have the graphic card driver installed? –  LnxSlck Oct 8 '12 at 13:02
    
I do! It looks like I have this as graphics: Intel® IGD x86/MMX/SSE2. With windows I was able to customize the resolution by messing with the regedit stuff. I'm looking to do the same thing with 12.04. My monitor can take the larger resolution, AND all of the side panel stuff in my Chromeo is huge. I should probably find a way to make that stuff smaller. Thanks for the comment! –  jayb151 Oct 12 '12 at 0:53
    
Have you installed the package mesa-utils? –  LnxSlck Oct 12 '12 at 8:31
    
Yes I have! That's how I got the computer to recognize what graphics I was running. before I installed that, it said graphics unknown. –  jayb151 Oct 12 '12 at 18:47
    
I still haven't found an answer to this. Anyone who can help, please do! It's really annoying that I can't make the screen any bigger, especially since when menus pop up, I can't even hit the buttons on the bottom like "cancel" or "save." Please Help! –  jayb151 Oct 16 '12 at 3:05
show 4 more comments

1 Answer 1

Try the following and let me know how this works or you:

Create a rudimentary xorg.conf using the following commands:

cd /etc/X11 Xorg –configure

mv ~/xorg.conf.new xorg.conf

vi xorg.conf

Use PAGE-DOWN to scroll the text until you see the line reading Section “Device”. Using the DOWN arrow, move the cursor to the indented line that starts with the word “Driver”. It may look like the following:

Driver “fbdev”

Move the cursor to the first letter inside the quotation marks and type “cw” – must be lowercase letters – and the word inside the quotation marks will disappear but the quotation marks will remain. Notice that “-- INSERT --” will appear on the bottom line of the screen.

Type vesa within the quotation marks still on the screen.

Press ESC.

Move the cursor down until you see the line reading

Section “Screen”

Indented are several lines. Move the cursor to the line below the line reading

Monitor “Monitor0”

Type the letter “O” – that is, a capital-O – and a blank line opens between the two lines. The cursor appears at the beginning of this blank line.

Press TAB to align the cursor with the word “Monitor” on the line above and then type DefaultDepth 24.

Notice that both words are capitalized, but there is no space between “Default” and “Depth” although there is at least one space between “Depth” and the number 24.

Press ESC.

  1. Type “G” – must be a capital-G – and the cursor will go to the bottom line of the

file. You should see a subsection for “Display” having a depth of 24. If you do not see that and, in case you passed it, using PAGE-UP or the UP arrow to scroll back does not reveal it, you can add one as follows:

a. Put the cursor on the unindented “EndSection” up against the left margin.

b. Type an “O” – must be capital-O – to open a blank line above the unindented “EndSection” line.

c. Using TAB to indent each line as follows, type the following text:

SubSection “Display”

Viewport 0 0

Depth 24

EndSubSection

Press ESC.

Type “ZZ” – must be two capital-Z letters – to save and quit the editor.

Run the command startx to begin the X Window System as the root user. Eventually, root’s desktop should appear.

Check the resolution that X selected by default using System -> Preferences -> Hardware -> Screen Resolution and change it to the appropriate setting as needed.

Open a terminal using Applications -> System Tools -> Terminal.

Run the program glxgears to see an approximation of your graphics frame updating speed.

Quit X using the logout option in the System menu or using CTRL-ALT-BACKSPACE.

Source

share|improve this answer
    
I put the first command in, and this is what I got: Section "Device" Identifier "Configured Video Device" EndSection Section "Monitor" Identifier "Configured Monitor" HorizSync 30.0-62.0 VertRefresh 50.0-70.0 EndSection Section "Screen" Identifier "Default Screen" Monitor "Configured Monitor" Device "Configured Video Device" DefaultDepth 24 SubSection "Display" Depth 24 Modes "1024x768" "800x600" EndSubSection EndSection –  jayb151 Oct 18 '12 at 2:33
    
That's the video configuration, did you ran startx ? –  LnxSlck Oct 18 '12 at 9:59
    
When I ran it, I got this output...X: user not authorized to run the X server, aborting. –  jayb151 Oct 19 '12 at 2:02
    
Try running it as the normal user –  LnxSlck Oct 19 '12 at 8:59
    
I put in the second command and I got this: barzyk@barzyk-Asus:/etc/X11$ mv ~/xorg.conf.new xorg.conf mv: cannot stat `/home/barzyk/xorg.conf.new': No such file or directory –  jayb151 Oct 21 '12 at 1:36
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.