Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The open source driver worked well with the fresh installation of Ubuntu 12.04, but it drains my laptop battery faster. So I installed the proprietary driver from jockey-gtk. It gave me this error message at the end of the installation:

enter image description here

After restarting the computer, I lost all the compositing animations. Compiz visual effects don't work. There is a black boarder around Docky.

enter image description here

I tried:

sudo apt-get --purge remove fglrx*

...which cleaned up the proprietary driver so I could install it again, but the same issue occurred again.

fglrxinfo returns this:

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66 ()
Serial number of failed request: 13
Current serial number in output stream: 13

Here is the jockey.log & the fglrx installation log

Please somebody help me...! Thanks!

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I've had similar problems, while installing the ATI driver through Jockey.

I suggest you go with a manual installation by following this excellent answer http://askubuntu.com/a/126513/47681

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.