Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Brand new to Linux, getting frustrated trying to get an environment up with Ubuntu. My primary goal is to learn Linux and Apache/PHP development. I need to keep my Windows OS as main on my machine for work, so I'm trying to virtualize Ubuntu 12.4.1 without luck (many attempts). I have a new HP Envy 4t-1000 with 16GB RAM, and 32 GB SSD caching with 500gb spindle hard drive. Graphics card is an Intel HD 3000 with AMD Radeon 7670M.

With installing Ubuntu desktop in VBox, I'm getting this result: Ubuntu installs failing. Suspect hybrid SSD/spindle drive

With VMware workstation 7 (patched), I complete the install of Ubuntu, it reboots, purple desktop briefly flashes then it drops to command line. I bought a beginning Ubuntu book, and it recommends trying to manually configure graphics if this happens. So I tried doing a safe boot holding shift - I get to the first screen (GRUB) loads fine, and I choose recovery mode. After choosing the recovery mode, I get the recovery mode options, and can arrow down to what the book suggests 'Run in fail safe graphic mode.' Once I select this option, I get a black screen with a large white dialogue box, at the top it says "The system is running in low-graphics mode. Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself." Then there is an OK button way down at the bottom. When I select 'OK' I get a menu for a few options, book recommended 'reconfigure graphics.' When I try this, I get a menu of two options:

  1. "Use generic (default) configuration
  2. use backup

I've tried both options several times, hitting OK just refreshes screen and nothing more. Rebooting at this point just goes back to command line as before.

I don't know what to do at this point, I've spent too many hours this weekend trying in both VBox and VMware to get Ubuntu going. Isn't there like a very basic graphic display or something I can use to at least get into the desktop?

I explored the GRUB some more, and tried to look at the startup and xserver logs - both are blank. No help there I guess? When I try to choose 'Edit the configuration file, then 'OK' screen just refreshes on same menu options, nothing happens.

Thanks for any advice. I really need to focus on learning Linux, Apache and PHP, so perhaps Ubuntu just won't work on my hardware? Any other suggestions? I will need to virtualize.

share|improve this question
1  
If you want to learn linux to use it as a server, as you stated, then you should probably focus on learning to use it from the command line, not the GUI. Most servers out there are not going to give you GUI access. –  Javier Rivera Oct 9 '12 at 7:45

2 Answers 2

It sounds like you have autologin selected, and Ubuntu is trying to start Unity 3D. All the hardware is virtualised, and the graphics does not have the 3D acceleration that Unity 3D requires. Assuming it is crashing to a usable terminal console:

Login and then edit the lightdm.conf file:

sudo nano /etc/lightdm/lightdm.conf

Change the line ""autologin-user=username" to just "autologin-user=". Press ctrlo to save and ctrlx to exit nano editor. Reboot the computer

sudo reboot

and it should boot up to the lightdm login screen. Click the Ubuntu logo on the panel next to your login name. Select Unity 2D, then login as per usual. If you fluff the password you'll have to select 2D again when you try again - it may default back to 3D

share|improve this answer

I've the same problem . but I solved it unexpected. I check the startx log and then log in the tty2 remove the file .Xauthority in my home directory. I get the normal system after reboot it . Hope useful for you .

share|improve this answer
    
Can you explain in greater detail how you did this, include the command(s) you used? –  Eliah Kagan Jan 3 '13 at 3:58
    
Ctrl + Alt + [F1-F6] or right Ctrl + [F1-F6] anyway what you need is just log in to tty. and delete the file: "rm .Xauthority" in your "home" directory then: "sudo shutdown now -r " –  benhuan Jan 4 '13 at 5:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.