Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This red icon.... It showed up after I upgraded to Ubuntu 12.04LTS; I can't figure out how to ditch it. It seems to be a notification thing. I am at a loss. The icon is here:

red mark

I clicked it and read this:

An error occurred, please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was:

'Error: BrokenCount>0'.

This usually means that your installed packages have unset dependencies.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

It's letting you know that the package system is in a broken state (eg. some of the packages are in a broken state). You can try to resolve this by running the following command in a terminal.

sudo apt-get -f install
share|improve this answer
1  
I tried that and it did nothing :( –  Ceil Oct 7 '12 at 23:23
    
Try updating the system and see if you get any errors "sudo apt-get update". Paste any errors you get into your original question. –  fabricator4 Oct 7 '12 at 23:40
    
I deleted the packages in question. Not only is the icon gone, but my system is running faster. –  Ceil Oct 8 '12 at 0:34
    
What packages were in question? –  Thomas Boxley Oct 8 '12 at 5:21

Please get correct package name which is been broken. You can use following command to get all package list.

sudo dpkg --get-selections > list.txt

Find correct package name from the list(created in home folder).

And use following command to remove package forcefully.

sudo dpkg --force-all -P PACKAGE NAME

ex- sudo dpkg --force-all -P texlive-pstrick-doc (texlive-pstrick-doc is package name)

Next run update command.

sudo apt-get update

This works for me. Thanks

share|improve this answer

I got this same red and white warning icon and identical error code after having tried to install the wrong package accidentally (i386 on amd64 - Ubuntu 12.04 LTS) To resolve I...

  1. ran dpkg --get-selections > ~/Desktop/packages in terminal to get a list of installed packages
  2. removed the package that I had just tried to install using the name of the package as appearing in the above list and this command sudo apt-get purge name-of-package-here
  3. ran the command above sudo apt-get -f install thanks tgm4883
  4. removed some redundant packages with sudo apt-get autoremove (the suggestion appeared in terminal after running the prior command.) Either here or the command before resulted in the warning/error disappearing
  5. I then ran sudo apt-get update which took much longer than usual and everything seems to be back to normal.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.