Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I open a fresh instalation of playonlinux, it gives 2 dialog box as mentioned in title:

playonlinux is unable to find 32bits OpenGL library
playonlinux is unable to find 64bits OpenGL library

I am using Ubuntu 12.04 (and new to it) and would like to know how to solve this problem


~$ playonlinux
[main] Message: PlayOnLinux (4.1.8) is starting
[clean_tmp] Message: Cleaning temp directory
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
[Check_OpenGL] Warning: 
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
[Check_OpenGL] Warning: 
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plugin: Capture...
[maj_check] Message: Web version : 1349866727
[maj_check] Message: Current local version : 1349563245
[maj_check] Message: Updating list
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
/usr/share/playonlinux/bash/startup_after_server: line 38: [: : integer expression expected
/usr/share/playonlinux/bash/startup_after_server: line 38: [: : integer expression expected
[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1349866727

EDIT Nvidea print screens enter image description here

What it says:

enter image description here

share|improve this question
Can you please provide your hardware specs and which video driver you are using. – Anthony Oct 12 '12 at 3:13
@Anthony as I said I am new to ubuntu. If you tell me how to find a dump for you I will put that up. Besides that. Mine is a lenova ideapad U410 i7 3rd gen laptop. – footy Oct 12 '12 at 3:35
Please launch playonlinux from the command line and report the output in your question. Open a terminal and type "playonlinux". I suspect there is a driver issue. Whether you should be using the nvidia hardware or the intel HD4000 we will see. – Anthony Oct 12 '12 at 4:51
@Anthony I have added it – footy Oct 12 '12 at 7:06

This is a tentative answer, a revision or additional information may be needed.

Find the pci BusID of your nvidia gpu. Open a terminal and type lscpi |grep VGA:

anthony@terminal:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
06:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)

Edit your xorg.conf file to load the nvidia driver. Open a terminal and type:

gksudo gedit /etc/X11/xorg.conf

Add to that file:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 430"
    BusID          "PCI:1:0:0"                   # Use lspci | grep VGA to find BusID

Section "Module"
    Load           "glx"

Edit the above example to include your hardware specific information. A reboot is needed after the alteration. This should be enough to get the nvidia driver loaded. Additional configuration may be performed by typing sudo nvidia-settings in the terminal.

share|improve this answer here is the log file. But still the error dialog boxes come. I followed your steps to add the text. I added it to the end of the file. – footy Oct 14 '12 at 0:51
I'm going to suggest that you install the nvidia driver. The nvidia hardware you have is slightly better than the intel hd4000 anyway. Follow this guide here You can also install it through synaptic package manager. Once the install is complete, you should be all set up. Let me know once you are finished and I will help you with additional configurations as needed. – Anthony Oct 14 '12 at 1:26
Hi nvidea is already installed and when I open it from dash board it says nvidea is not being used and in-order to use it just enter nvidea-xconfig as root. I did that. But my resolution got weird. It wouldnt go beyond 640x480. And I tried MANY solutions on the internet and put in the exact resolution of my monitor. I had to reinstall ubuntu – footy Oct 15 '12 at 14:48
The "need" to reinstall nvidia aside, how was it installed in the first place? From Additional Drivers, or from nvidia directly? Second, although using nvidia-xconfig can be useful, it is my experience that it is not always 100%. – Anthony Oct 15 '12 at 18:02
I didnot install it explicitly from any-source. My best guess is that: I am connected to the internet while installing ubuntu, and I did check the options to update-ubuntu and install required 3rd party drivers (in the installer first screen) – footy Oct 15 '12 at 18:08

I had this problem and i repaired with those :

Remove all parts of playonlinux and wine .

setup wine(first) and Playonlinux . after update your nvidia drivers on nvidia driver page (only download and setup it )

That's it :)

share|improve this answer
Nope, it actually crashed my system to a 640x480 screen and I had to restore the system – footy Oct 18 '12 at 12:44

You need to install your proprietary drivers for your Nvidia. Go to "System Settings > Additional Drivers" and install the one who's not "post-release".

I found one solution on Ubuntu Forums in a Wine/PlayOnLinux thread :

"Okay, so I repeatedly purged and installed POL, eventually deciding to delete the file "/etc/apt/sources.list.d/playonlinux.list" (although I am pretty sure the word old was in there somewhere) as I was getting errors when using "apt-get update" to do with this file. This seems to have rectified the problem with the request for 32- and 64-bits OpenGL libraries."

I think you're having the same problem, so try this solution.

share|improve this answer
I tries this, didnt sove the problem – footy Oct 18 '12 at 12:44
up vote 0 down vote accepted

This may sound strange, but here is how I got it working! This is not a real answer

I unistalled ubuntu ( I was on 12.04 ) and I installed the new Ubuntu 12.10 ... I then installed wine first and then playonlinux , both from the ubuntu software center. It worked like a charm :)

Thanks for all your help in answering this, but I still havent figured out whats wrong with that as its working now and I am not in a mood to crash my playonlinux to solve it!

share|improve this answer
No need to reinstall Ubuntu or playonlinux in whatever order. The trick is to just install wine, because it depends on libgl1-mesa-glx | libgl1 for both amd64 and i386 architectures. That works for in-kernel-tree graphics drivers as well as proprietary ones. – David Foerster Oct 15 '14 at 14:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.