Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a TP-LINK TL-WN781ND Wireless N card with an AR9285 chipset and an ath9k driver on Xubuntu 12.04.1 with Network manager.

iwconfig wlan1 shows that it's using a bit-rate of 54 Mb/s. Is there a way (e.g. through an 'options' entry in /etc/modprobe.d/ath9k.conf) of forcing it to use mode N? My router is doing 'Mode B/G/N Mixed'.

share|improve this question
1  
If the driver supports it, you could try sudo iwconfig wlan0 modu 11n, and for the module options, have a look at modinfo ath9k. That said, there is probably a reason it uses 11g. Are there 11g only devices that connect to the router? If not, try disabling the mixed mode on the router. – mikewhatever Oct 7 '12 at 22:42
    
The 'iwconfig' mechanism would probably break any existing connection set up by Network Manager. And 'modinfo' doesn't show any 'parm' parameters that look appropriate. So I've disabled mixed-mode on the router .. but that's likely to upset some of my visitors in the future. Any other suggestions? – Graham Oct 8 '12 at 7:09
    
show us bitrate support: update with $sudo iw list – j0h Jan 21 '15 at 4:37
    
I bit-rate of 54Mb/s doesn't mean that it is in 802.11g mode. It could be that other of the devices that you have on your network only works on g mode? I can't remember de command now but when you get the bit-rate, does it also appear a MCS parameter or similar? Look this link mcsindex.com you can see that it's possible to working in 802.11n mode at a rate of 54Mbps. That's common if the conditions are not good enough for WiFi – migrc Apr 28 at 15:04

It's possible your signal quality is too low to support 11n communications. 11g has less throughput but more reliability than 11n. If you were really far out of range, your machine would switch to 11b. I have had machines that do this and I love it. I'd rather have slow network than no network.

To fix, I'd get an external antenna for your router, one with some gain to it. These can be had cheaply from various online retailers, including Amazon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.