Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am currently trying to backup data from my computer's hard drive to an external one while live-booting to Ubuntu from a USB, and I've encountered a bit of a problem. You see, I cannot mount my hard drives. Whenever I try, I always get one of two errors:

fuse: failed to access mountpoint [file I'm trying to mount to]: No such file or directory


Error mounting: mount exited with exit code 21: mount: according to mtab, [drive] is already mounted on [file I'm trying to mount to]

How can I fix this?

EDIT: So it turns out that there was something wrong with the usb I was live-booting from. I just tried it with a different one and it worked fine.

share|improve this question

The errors are pretty self explanatory for what i can see, the first one needs a real mount point, meaning that if you are mounting a filesystem under a folder that does not exist you simply can't; the second one is saying that your filesystem is already mounted, just analyze the output of cat /etc/mtab and see if it's true, probably you will find your filesystem already mounted.

share|improve this answer
As far as I can tell, they're not mounted anywhere. cat /etc/mtab gives me cat: /etc/mtab: Input/output error – mixtyplix Oct 7 '12 at 21:35

In the first instance, the directory that you are trying to mount the device to does not exist. Even though you will read that directories are actually "files" in the Linux filesystem, for the purposes of mounting the mount point must be a directory. A general mount point that is always available on a Linux filesystem is /mnt so the command

sudo mount /dev/sda1 /mnt

will always mount the first partition on the first hard drive at /mnt

The second error is telling you that the filesystem is already mounted at the mount point you have given it, either with a previous mount command, or by you trying to access it through Nautilus (for example).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.