Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Last time I restarted my computer, I could not get Ubuntu to load; the screen would either go black, or would hang at the purple screen indefinitely. I have had some graphics problems in the past, but had put 'nomodeset' after 'quiet splash' in the grub command line, which at least let Ubuntu load. That doesn't work now, and doesn't work if I remove it.

I looked up some answers, such as this one: Purple start screen - no splash screen However, when I enter the root in recovery mode in grub, I always get errors when I run those command lines and it won't let me modify the files.

Also, if I run in recovery mode and then choose 'resume normal boot', it will continue. But instead of getting a usual interface, I get a black screen that asks for my username and password. I enter these, and it tells me I'm in Ubuntu 12.04, but I'm still on a black screen with texts. It also informs me that there are updates to install. When I use the command 'sudo apt-get update', it starts to retrieve the information, but then the screen goes blank after a couple of seconds and I can't do anything anymore.

Any ideas?

share|improve this question

marked as duplicate by bain, Luis Alvarado Jul 24 '14 at 23:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Have you tried booting from CD/DVD Media (different OS) just to make sure that it has nothing / something to do with your installation? – Peterling Oct 7 '12 at 22:01
Yeah, when I try to boot from a live cd, I can't get any screen to load at all. – kara Oct 7 '12 at 22:47
Okay, after forcing a reboot several times I got the live cd screen to load, but then if I took any action, the screen would go blank again. – kara Oct 7 '12 at 22:52
Also, if I try to repair broken packages in recovery mode it says it cannot remove two files because they do not exist, and when trying to update in grub, it cannot retrieve all the updates. – kara Oct 7 '12 at 22:57

I was able to find the answer by going an alternate route, suggested here: How can I uninstall a graphics package in recover mode?

Though I had to go a roundabout way to actually use the command, I was able to uninstall the last package I had updated, and my desktop loaded back up.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.