Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Cant boot into windows after installing ubuntu

The First time I tried to install Ubuntu the installer installed it on my D drive. This resulted in only booting to Windows XP with no access to Ubuntu. I had to download a disk partitioning program to undo all of this. A tip from the Internet said to create a partition on the C drive for Ubuntu, so I did along with a Swap Partition. I did this manually because the installer on the CD would not do so and would not let me do so from within the installer program.

With the fresh partitions created for Ubuntu I let the installer do its thing. The computer rebooted and came up in Ubuntu. I then installed WINE and all was well. Then I shut the computer down for the night.

The next day I turned on the computer and it booted directly into Ubuntu. I can see the Windows partition and all the files but it will not allow me to switch to the Windows XP OS. Does not even give me a choice to do so. I have reinstalled Ubuntu several times and each time is the same, I cannot access Windows XP anymore.

Right now I am in a fresh install with only whatever the installer installed. How do I fix this?! I have tried the hold the shift key to see if something called GRUB shows up, but no. I tried shifting the order of boot in GRUB but that did not work either. I tried using EasyBCD but that will not run.

One symptom I do not understand, my monitor will post a graphic when the computer reboots that the cable is disconnected, this is normal. Then when the computer gets to the actual boot process it will display the splash screens etc and it did this for Windows XP as well. But now something new has popped up, while booting Ubuntu after where it probably should be showing me a menu to pick what OS I want to boot, the monitor posts "Input Unsupported" until Ubuntu loads. I have never seen it post this before, maybe a clue to someone.

share|improve this question

marked as duplicate by Tom Brossman, hexafraction, Jorge Castro, Eliah Kagan, devav2 Oct 8 '12 at 4:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please follow the answer given by phoibos. –  hexafraction Oct 7 '12 at 21:38
add comment

1 Answer 1

Hm, it could be a problem with Grub's GFX mode. You could enable textmode for the boot menu:

Open the terminal and edit the file /etc/default/grub.cfg e.g. with nano:

sudo nano /etc/default/grub

And remove the # from the line

#GRUB_TERMINAL=console

so that it becomes

GRUB_TERMINAL=console

Save & exit. Then update the grub configuration with

sudo update-grub

In the output of the command, you should see a Windows entry somewhere. Now reboot and see if the boot menu appears.

share|improve this answer
    
This is exactly correct. –  hexafraction Oct 7 '12 at 21:37
    
I hope this is where I can answer. I tried your suggestion but the commands did nothing. So I tried using gksu gedit /etc/default/grub and from here I could remove the #. I think when I use the sudo update-grub I should see something happen but nothing does. For this reason I am not sure the grub things listed actually work. I rebooted and the same boot sequence as before happened, no menu to choose Windows XP or Ubuntu. The Input Not Supported was displayed and then Ubuntu boted up. –  Bob D Oct 7 '12 at 23:37
    
Open the terminal application and enter sudo update-grub there. There should be some output. –  phoibos Oct 7 '12 at 23:58
    
Okay I was using something I found on the Internet ALT F2. I searched for a Terminal Program and one opened. I tried the fixes again and this time I did see a Windows listed at sda1. SO I rebooted and a menu finally appeared. I also had uncommented the 640 by 480 portion of GRUB thinking that might help. In the menu is the list for Windows but when selected it went blank and then came back to the menu again. It will not boot into the Windows XP. –  Bob D Oct 8 '12 at 1:11
    
An addition to my last comment is that I thought I was using a Terminal App using the ALT F2, apparently when you do this it does not actually update the grub. In the ALT F2 line the command to alter the grub however did allow me to modify the grub contents and save it. Now that I can actually see the menu there must be something missing. Something that causes the Windows XP software to boot but I have no idea what that might be. It looks like the menu item when selected for Windows goes off to do its thing but apparently when it gets there, something is wrong. The menu returns. Ubuntu is OK. –  Bob D Oct 8 '12 at 4:55
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.