Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to do apt-get dist-upgrade but I get the error:

E: Could not perform immediate configuration on 'util-linux'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

How can I resolve this?

share|improve this question
My answer doesn;t apply now. Honestly, I don't know what to do, so I deleted my answer. – hexafraction Oct 7 '12 at 19:47
@ObsessiveSSOℲ: It was still helpful, though, because of the -O APT::Immediate-Configure=0 option. – Albert Oct 7 '12 at 19:56
up vote 4 down vote accepted

Messed up system, I guess.

I tried to do apt-get dist-upgrade -o APT::Immediate-Configure=0 but I got a dependency cycle error: E: Couldn't configure pre-depend multiarch-support for libnih-dbus1, probably a dependency cycle.

Then I tried to apt-get install -f libnih-dbus1 and got another error:

The following packages have unmet dependencies:
  libc6-dev: Breaks: cmake (< 2.8.4+dfsg.1-5) but 2.8.1-4~lucid1 is to be installed
E: Broken packages`

Then I tried sudo apt-get install libc6-dev which worked.

Then I did apt-get install util-linux -f -o APT::Immediate-Configure=0 which also worked fine.

So I think this problem is resolved now.

share|improve this answer
Don't forget to accept your own answer after 2 days. – hexafraction Oct 7 '12 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.