Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to do do-release-upgrade (also tried the graphical version before - same issue with less details).

It always get stuck downloading openjdk-6-jre-headless. The exact line

3% [18 openjdk-6-jre-headless 27.1 MB/27.3 MB 99%]

It always exactly downloads 27.1 MB, then stops and then it tries again. I already changed the server but no difference (tried http://de.archive.ubuntu.com/ubuntu/ and http://en.archive.ubuntu.com/ubuntu/ so far).

The direct link to the file is this. This file is about 26 MB (again different?).

Why is this? What's the problem? How can I fix it? Or work around it?

There are some similar questions, e.g. here orhere. The suggestions cannot really be applied for do-release-upgrade, though (or at least I don't know how).

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I'm not sure if this can count as an answer but I post it anyway because this is how I solved it now:

It seemed that it already modified my sources.conf with the precise (the latest Ubuntu) release. So I just tried with both apt-get upgrade and apt-get dist-upgrade. Initially, I got similar problems with openjdk-6-jre-headless but with some back and forth (I think mostly because of apt-get distupgrade), this somehow resolved. However, this also didn't finished completely and I got a very much messed up system.

Some follow up questions:

After I got this all resolved, I tried the do-release-upgrade again and it seems to work now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.