Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to integrate steadyflow download manager with chrome by installing chromeflow found at launchpad.net, but I recieve error that extensions can only be installed from chrome web store. I would also like to know if this can be done in Chromium or does it restrict similar to chrome?

share|improve this question

1 Answer 1

A workaround has been created, but it is not pretty. To bypass the protection, you need to download the extension or userscript to the local system. Once there, you need to drag and drop it into the chrome://chrome/extensions/ page in the browser. If you drag and drop it elsewhere, nothing will happen.

When you drop it on the extensions page, you will notice an install option popping up there.

When you select that option, you will see the standard installation dialog that informs you about the rights that the script or extension is requesting.

Sourced from: Chrome Fix: Extensions, apps, and user scripts cannot be installed from this web site.

Edited on 20121125:
I came across another way which requires starting the browser from the command line.
For example, if you are using Chrome and want to install an extension not from the Web Store, the following code entered in a terminal starts Chrome in a "permissive" mode for this instance:

google-chrome --easy-off-store-extension-install  

Explanation for the switch:

Enables extensions to be easily installed from sites other than the web store. Without this
flag, they can still be installed, but must be manually dragged onto chrome://extensions/.

Source: http://peter.sh/experiments/chromium-command-line-switches/

The usual caveats apply. The user should be careful about installing extensions. Commmand line switches come and go and need not work with earlier versions or future versions of the browser.

I can't answer about Chromium because I don't use it.

share|improve this answer
    
Thanks, the workaround works, able to install the addons, but have to verify whether they work without any problem. –  kunaguvarun Oct 8 '12 at 15:14
    
This doesn't seem to work for me; I get the 'drop to install' message, but when I drop the file Chromium simply opens the text file. There's no option, or indication, so far as I can tell, to actually 'install' anything. Is this a new change, or am I clearly not doing something right? –  David Thomas Nov 24 '12 at 22:57
    
@David Thomas, I've edited the answer. Please take a look. If your extension still doesn't install, I suspect there maybe something wrong with it. As mentioned, I don't use Chromium and so won't comment on that aspect. To my mind, the fix should work as it isn't "Chrome"-specific. –  user25656 Nov 25 '12 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.