Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using askubuntu extensively and now I am going to ask my first question here.

I am trying to get my 2.1 speaker working on my ThinkPad X60 and a 12.04LTS/unity/pulseaudio (00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)).

The front left/right is working fine, but I cannot get the lfe/subwoofer working.

Here is a subset of my pulseaudio conf:

enable-lfe-remixing = yes
...
default-sample-channels = 3
default-channel-map = front-left,front-right,lfe

I also notice the server sample tab in paman shows :

Default Sample Type: s16le 3ch 44100Hz

However in the device tab, the property of the sink is always s16le 2ch 44100Hz.

I also tried modify default.pa (load-module module-remap-sink OR module-alsa-sink) but it either doesn't work or switch to digital output which have no output at all.

Any idea will be very appreciated as this is something I have spent a whole morning to try to figure out...

share|improve this question

1 Answer 1

Try the follwing steps:

1.

echo 'options snd-hda-intel model=asus-mode4' | sudo tee -a /etc/modprobe.d/alsa-base.conf

2.

sudo gedit /usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

and add following lines to extra-hdmi.conf

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = front-left,front-right,lfe,lfe 
paths-output = analog-output analog-output-speaker 
priority = 7 
direction = out

3.

sudo gedit /etc/pulse/daemon.conf

and add following line to daemon.conf

enable-lfe-remixing = yes
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.