Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i own a sony vaio laptop VPCCB. i have ubuntu 12.04 installed side-by-side with windows 7. while using ubuntu the laptop gets heated a lot compared to windows and the fan keeps spinning continuosly. i have jupiter installed please help....

share|improve this question
    
probably you don't have all the drivers installed –  axis Oct 7 '12 at 16:16
    
how should i do that, please help –  Akshay Oct 7 '12 at 16:20
    
i am using ubuntu alongside windows 7 but it does not cause any problem in windows please help me with the driver installation... help!!!!!!! –  Akshay Oct 7 '12 at 16:37
    
As of Ubuntu 14.04, you no longer need to follow this method. The kernel v3.13 included has support for automatic graphics switching, so your external ATI graphic card will be in DynOFF state by default (OFF till it is really necessary. Enjoy!) –  Sagar_R Apr 24 at 19:49
add comment

2 Answers 2

up vote 2 down vote accepted

Hey even I have the same laptop. The problem here is that our laptop contains 2 graphic cards 1.AMD 6630 2.Intel HD 3000 Somehow, by default Ubuntu keeps both of them running, even if only one is used, that leads to overheating. The solution is to turn off one graphic card.Here I show how to disable ATI card, and just use the Intel HD graphics. Enter this command in the terminal to check the graphic card status

cat /sys/kernel/debug/vgaswitcheroo/switch

you will get o/p like

 0:DIS: :Pwr:0000:01:00.0
 1:IGD:+:Pwr:0000:00:02.0

here DIS=AMD card, IGD=Intel card. Pwr on both the lines means that both are powered.To turn the DIS off, enter

sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

check the status again. you should get Off on the 0:DIS line.This means only the low-power intel card is running.Use you laptop for an hour or two, and feel the difference. If it is indeed running cooler, to make the changes persist even after reboot, edit the rc.local file.

sudo gedit /etc/rc.local

and add the following line above exit 0

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
share|improve this answer
    
nice.. but wont it affect the applications i can't run without the amd graphics card?? –  Akshay Oct 7 '12 at 17:56
    
u r awesome!!! thanx –  Akshay Oct 7 '12 at 18:42
    
dude intel HD3000 is already very powerful for all productive work in ubuntu...all 3d transitions, effects work smoothly. so it wont be a problem –  Sagar_R Oct 8 '12 at 9:40
add comment

My Laptop is: Sony Vaio VPCCB B3M1E

In my case, I just did this:

sudo gedit /etc/rc.local

Added the following line above exit 0

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

And it solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.