Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a 4gb usb to boot ubuntu 12.04. It worked successfully, but after a reboot all of my data was gone and all the programs reverted back to their default. I did set a persistence thingy when I created it using the bootable usb creator tool.

Any help would be greatly appreciated! :)

share|improve this question
3  
Are you absolutely sure that you set persistence when you created the USB? You may want to try recreating the Live USB, just in case. The other possibility is that either you did not shut down properly or you removed the USB stick before shutting down, causing the data not to be written from the cache. One more option: Does your USB stick have a read-only switch that you accidentally set after creating it? –  Paddy Landau Oct 7 '12 at 14:08
    
That sounds like the problem, my laptop's battery had died. Thanks for the help! –  Josh Dupras Oct 7 '12 at 15:12
1  
Rather than closing this as too localized, I recommend @PaddyLandau make an answer from that comment, as this situation is likely to recur for others. –  Eliah Kagan Oct 8 '12 at 0:14
1  
@EliahKagan, I shall do as you suggest, along with another option that I hadn't thought about. –  Paddy Landau Oct 8 '12 at 8:48
add comment

closed as too localized by Jorge Castro, maythux, Mitch, devav2, Stephen Myall Oct 8 '12 at 10:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

What you describe should have worked. Please check the following.

  • When you downloaded the ISO from which to create the USB, did you check the MD5 sum of the ISO? Refer to How to MD5 Sum and the List of MD5 Hashes.
  • Are you absolutely sure that you set persistence when you created the USB? Try recreating the USB.
  • When you finished your session, did you shut down properly, or did you remove the USB before the computer had shut down? If not, the data might not have had a chance to be written from the cache. Remember that USB is much slower than a hard drive, and data can take many seconds or even a couple of minutes to write to a USB. (As reported by Josh Dupras, this can also happen if the power fails.)
  • Does your USB stick have a read-only switch that you might have accidentally set?
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.