Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had this papercut for a while now, it's time it was fixed.

When I boot up Ubuntu, choosing "Ubuntu...generic" from the grub screen, Ubuntu fails to load. It just sits at the driver/module loading screen. What seems to be the most significant line in this output is "xhost: unable to open display"

If I choose "Ubuntu...(recovery mode)" from grub then it loads OK.

I don't get why this is.

Out of interest I tried enabling boot error logging with

#/etc/default/bootlogd
BOOTLOGD_ENABLE=Yes

but I'm not seeing anything in that file.

ETA:

I've had this problem since fresh install of 11.10.

Here's lshw:

$ sudo lshw -C display
  *-display               
       description: VGA compatible controller
       product: GF104 [GeForce GTX 460]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f6000000-f7ffffff memory:e0000000-e7ffffff memory:ec000000-efffffff ioport:bf00(size=128) memory:e8000000-e807ffff

*Edit: I thought I'd fixed the problem by disabling BOINC, but this only worked for the first reboot. Reboots after, and subsequent, failed to make it to gnome login.

Things I've done to try and fix the problem:

  • Remove /etc/X11/xorg.conf
  • Disable BOINC
  • sudo mkdir /etc/exports.d

My /var/log/boot.log now looks like this:

fsck from util-linux 2.19.1
/dev/sdb1: clean, 648476/3121152 files, 3926355/12471552 blocks (check in 5 mounts)
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
 * Starting AppArmor profiles       [80G 
[74G[ OK ]
 * Exporting directories for NFS kernel daemon...       [80G 
[74G[ OK ]

Any help would be appreciated.

share|improve this question
    
The most likely reason is a problem with the graphics module. Recovery mode might be using a lo-res default mode. You should make sure that correct graphics module is installed - give the output of "sudo lshw -C display. Some background would be nice also - did the problem start after an update or upgrade, or is this a new installation? –  fabricator4 Oct 7 '12 at 13:08
    
updated with lshw –  paulus_almighty Oct 7 '12 at 14:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.