Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i created hibernate option using _

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

and i added this in that file_

[Re-enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

but its not working. when i click on it, come to desktop page after some tym what need to do . is anything wrong?

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x426556e7

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    81915434    40957686   83  Linux
/dev/sda2        81915496   625137344   271610924+   f  W95 Ext'd (LBA)
/dev/sda5        81915498   255995774    87040138+   7  HPFS/NTFS/exFAT
/dev/sda6       255995838   430076114    87040138+  82  Linux swap / Solaris
/dev/sda7       430076178   625137344    97530583+   7  HPFS/NTFS/exFAT
         total       used       free     shared    buffers     cached
Mem:       2025828    1372148     653680          0     135104     772580
-/+ buffers/cache:     464464    1561364
Swap:      4194300          0    4194300

#free
 total       used       free     shared    buffers     cached
 Mem:       2025828     864896    1160932          0      28972     380768
 -/+ buffers/cache:     455156    1570672
 Swap:      4194300      79680    4114620
share|improve this question
    
You might not have room for hibernation. Please give the results of the following: "sudo fdisk -l && free" –  fabricator4 Oct 7 '12 at 9:23
    
Disk /dev/sda: 320.1 GB, 320072933376 bytes 255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x426556e7 Device Boot Start End Blocks Id System /dev/sda1 * 63 81915434 40957686 83 Linux /dev/sda2 81915496 625137344 271610924+ f W95 Ext'd (LBA) /dev/sda5 81915498 255995774 87040138+ 7 HPFS/NTFS/exFAT /dev/sda6 255995838 430076114 87040138+ 82 Linux swap / Solaris –  V Rohan Oct 7 '12 at 9:40
    
Thanks, you've got a big enough swap file - maybe 50 times too big. You missed the free command though, which would tell us if it was using it. Please type the command "free" and give us the output. –  fabricator4 Oct 7 '12 at 10:17
    
I confirm the correct file is /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla, not /var/lib... –  fabricator4 Oct 7 '12 at 11:05
    
Something strange here - the swap partition appears to be huge - /dev/sda6 is 166Gb. Maybe someone could check my figures? The swap given above is 4Gb. Is it a swap file? Linux hibernation to a swap file is none-trivial and needs to be set up correctly by my understanding. –  fabricator4 Oct 7 '12 at 11:09
show 1 more comment

2 Answers

You need to edit files in: /etc/polkit-1/localauthority/50-local.d/.

You could do the following:

  • Open the file.
gksudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla
  • Type the following and save:
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
  • Log out and log back in.
share|improve this answer
    
it is showing _ option_instat_callback:error -84 PM:swap header not found –  V Rohan Oct 7 '12 at 9:35
    
when? where? how? –  green7 Oct 7 '12 at 9:40
    
when i click on hibernate option, after that showing black screen and after some time .. gave that out put , and come back to desktop. –  V Rohan Oct 7 '12 at 9:44
    
Make sure pm-hibernate is installed. Open a terminal and run pm-hibernate. See if it hibernates your machine. –  green7 Oct 7 '12 at 10:17
    
this is giving me black screen and showing errors_ option_instat_callback:error -84 PM:swap header not found –  V Rohan Oct 7 '12 at 10:24
show 6 more comments

Might be a silly reason, but I had to update my graphics driver with the additional drivers program for mine to work.

share|improve this answer
    
then what i need to do? –  V Rohan Oct 8 '12 at 7:22
    
It was just a matter of going into the additional drivers program in the list for me. My card is an ati. One drive works, one would not install. –  Bryan Oct 8 '12 at 10:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.