Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to connect to this network for quite some time. I can't directly connect to the router with a Wire, but can access the Router with other wireless devices without any issues.

I had previously tried several other Wifi nic's but none of them would load properly.

Today, i went and bought a new (supported) Sabrent A111N USB Dongle, which said explicitly that it works with Linux 2.4 +.

I popped the Dongle in, and low-and-behold it immediately said that there were Available Wireless Connections. I selected my connection and tried to connect, but it just loops constantly while saying Wireless Disconnected then attempts to connect again over and over.

ifconfig and iwconfig both show my device in a ready and working state. However, iwlist wlan0 scan says that there are no results found. I don't get it...

At one point, I could see the CPU in the DHCP client list under the router, but it doesn't fully make the connection (something about a timeout?).

Any help would be appreciated.

Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN

share|improve this question
up vote 1 down vote accepted

While RTL8188CUS is indeed supported, and should work out of the box, and yet, there are reports around the WWW that it doesn't. The device 'sees' the networks around, but won't connect to them. Here is a bug report.

That said, you can get it to work by downloading and installing the driver from Realtek. The device uses the rtl8192cu module by default, which can be varified by running lsmod | grep 8192 in a terminal.

  1. Download RTL8192CU for Linux from Realtek.

  2. Right click the downloaded file, select Extract Here.

  3. Before installing, you need to blacklist the broken module, so run the following and reboot.

    echo 'rtl8192cu' | sudo tee -a /etc/modprobe.d/blacklist.conf

  4. Now open a terminal window and change to the driver folder

    cd RTL8188C_8192C_USB_linux_v3.4.4_4749.20120806

  5. Run sudo bash ./

Wireless should start working now. You'll need to reinstall the driver after every kernel update.

share|improve this answer
This fixed it. I tried this method previously and used the wrong drivers! I blacklisted the other ones then followed your instructions and BAM! Thanks bro. – Ohgodwhy Oct 7 '12 at 3:22

I have two different USB wifi dongles that use the rtl8192 driver automatically to connect. Both dongles will find signals and connect for up to 45 minutes at a time. However; they both predictably drop wifi connections and refuse to reconnect without a restart.

Blacklisting the rtl8192 driver and installing the Realtek driver from the official site has corrected the issue.

Open the Terminal and type:

sudo gedit /etc/modprobe.d/blacklist.conf

Add to the bottom of file, save, and close:

blacklist rtl8192cu

Download the driver and extract. In Terminal navigate to driver folder using ls and cd commands.

Using the Terminal-once in driver folder type:

sudo make
sudo make install
sudo clean

I downloaded and installed the RealTeck RTL8188CUS driver because I verified it worked well on a previous install; however the network connections manager still shows rtl8192 in use. Odd because the driver is blacklisted and it's not the one I downloaded. file did not work for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.