Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using MountManager in Ubuntu 12.04 to set user permissions in mounting hard drives. I set each partititon to be mountable by everyone instead of admin only. Then I clicked Apply in the file menu and it gave me the message successfully updated.

Upon restarting Ubuntu, just hangs on the splash screen and does not boot any further. Windows still boots fine.

How can I fix these? please help

thanks

From LiveUSB:

my fstab looks like:

overlayfs / overlayfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0
/dev/sda7 swap swap defaults 0 0

Is this corrupted?

Other things that may be helpful:

blkid returns

/dev/loop0: TYPE="squashfs" 
/dev/sda1: LABEL="System Reserved" UUID="0AF26C31F26C22E5" TYPE="ntfs" 
/dev/sda2: UUID="5E1C88E31C88B813" TYPE="ntfs" 
/dev/sda3: UUID="94B2BB7DB2BB6282" TYPE="ntfs" 
/dev/sda5: UUID="41b66b9a-2b48-45cf-b59d-cd50e41ec971" TYPE="swap" 
/dev/sda6: UUID="c73ca79e-4fa4-4bde-967e-670593736f6a" TYPE="ext4" 
/dev/sda7: UUID="c05d659f-103c-4444-9dc4-3121b9e081d6" TYPE="swap" 
/dev/sdb1: LABEL="PENDRIVE" UUID="1DE8-0A49" TYPE="vfat" 

and cat /proc/mounts

rootfs / rootfs rw 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,relatime,size=1950000k,nr_inodes=206759,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,relatime,size=783056k,mode=755 0 0
/dev/sdb1 /cdrom vfat           rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,erro     rs=remount-ro 0 0
/dev/loop0 /rofs squashfs ro,noatime 0 0
tmpfs /cow tmpfs rw,noatime,mode=755 0 0
/cow / overlayfs rw,relatime,lowerdir=//filesystem.squashfs,upperdir=/cow 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,relatime 0 0
none /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
none /run/shm tmpfs rw,nosuid,nodev,relatime 0 0
gvfs-fuse-daemon /home/ubuntu/.gvfs fuse.gvfs-fuse-daemon      rw,nosuid,nodev,relatime,user_id=999,group_id=999 0 0
share|improve this question
add comment

2 Answers 2

I managed to use the liveCD to edit /etc/fstab. I first mounted the linux partition (sda6 as I found using blkid above (ext4)) and made a copy of the corrupted fstab

mkdir rootmount
mount -t ext4 /dev/yourrootpartition ~/rootmount
sudo cp ~/rootmount/etc/fstab ~/rootmount/etc/fstab.broken

I then did

sudo gedit ~/rootmount/etc/fstab

to create a new fstab as

# Begin /etc/fstab

# file system  mount-point  type   options         dump  fsck
#                                                        order

UUID=0AF26C31F26C22E5   /media/SystemReserved   ntfs-3g defaults    0   0
UUID=5E1C88E31C88B813   /media/5E1C88E31C88B813 ntfs-3g defaults    0   0
UUID=94B2BB7DB2BB6282   /media/94B2BB7DB2BB6282 ntfs-3g defaults    0   0
UUID=c73ca79e-4fa4-4bde-967e-670593736f6a   /media/c73ca79e-4fa4-4bde-   967e-670593736f6a  ext4    defaults    0   0
UUID=41b66b9a-2b48-45cf-b59d-cd50e41ec971   swap    swap    sw  0   0
UUID=c05d659f-103c-4444-9dc4-3121b9e081d6   swap    swap    sw  0   0

using the tutorial http://www.tuxfiles.org/linuxhelp/fstab.html (the UUID obtained from blkid identifies the partition instead of writing things like /dev/sda1 etc). Not sure if this is exactly how it's supposed to be setup, but now my computer boots at least!

share|improve this answer
add comment

It seems bootmanager messed up your etc/fstab file. I suggest booting through a CD or USB and modify it again. If you do not know how to modify an fstab file, google it or post your fstab file here for detailed help.

share|improve this answer
    
thanks, added some more info from the boot into the liveUSB –  fpghost Oct 6 '12 at 21:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.