Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm complete new to Ubuntu so please pardon my ignorance.

Every time I install something I get the same error at the end. for example...

sudo apt-get clean && sudo apt-get autoremove 
Fetched 386 kB in 0s (545 kB/s)       
dpkg: error processing lib32asound2 (--configure):
 package lib32asound2 is not ready for configuration
 cannot configure (current status `half-installed')
Errors were encountered while processing:
 lib32asound2
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried to remove and reinstall this package:

sudo apt-get install lib32asound2 

but with no joy same issue.

How can I resolve?

P.S. I'm running 64bit Ubuntu 12.10 beta 2. Error came after trying to install Skype which failed.

Many thanks

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Fix it by typing

sudo dpkg --remove --force-remove-reinstreq lib32asound2
share|improve this answer

Try purging it.

sudo apt-get remove --purge lib32asound2

And then install it again if you want / need it.

share|improve this answer
    
Tried that too, but i get the error Package is in a very bad inconsistent state. however I have reinstall and get an error too! :( –  Spike Oct 6 '12 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.